Closed Bug 914229 Opened 8 years ago Closed 8 years ago

Cannot save bookmarks to json file

Categories

(Firefox :: Bookmarks & History, defect)

24 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Firefox 29

People

(Reporter: unknownBut2me, Assigned: mak)

References

Details

Attachments

(1 file)

From bookmarks window: Alt+ib.  Select folder. Select current backup, ex. "bookmarks (Main)-2013-08-29.json".  Edit date to current, ex. ...2013-09-09.json.  Click Save.

Zero byte file "bookmarks (Main)-2013-09-09.json" is created.  After approx. five seconds it's deleted somehow.

New file "bookmarks (Main)-2013-09-09.json" created and saved.  Size of this file will be larger/smaller than previous save, ex. 623,805 bytes +- n bytes, if new records/edits have been added/edited.
is this reproducible in Safe mode? http://support.mozilla.org/kb/Safe+Mode
also, are you manually saving a backup inside the browser's bookmarkbackups folder?
(In reply to Marco Bonardo [:mak] from comment #1)
> is this reproducible in Safe mode? http://support.mozilla.org/kb/Safe+Mode

Yes - same result in Safe mode.
(In reply to Marco Bonardo [:mak] from comment #2)
> also, are you manually saving a backup inside the browser's bookmarkbackups
> folder?

Yes - from Ctrl-Shift-b, but to another (safer) drive/folder.
This is on version 24, right?

Could you by chance try to create a new profile and see if from that profile you are able to save a json backup? I'd like to understand if there's an issue at the product level or at the bookmarks database level.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Also, I'd suggest to try by temporarily disabling the antivirus, even just for 10 minutes, to exclude its interaction.
(In reply to Marco Bonardo [:mak] from comment #5)
> This is on version 24, right?
> 
> Could you by chance try to create a new profile and see if from that profile
> you are able to save a json backup? I'd like to understand if there's an
> issue at the product level or at the bookmarks database level.
> https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> profiles

Yes - v24

Created new profile - Problem is gone!
(In reply to Marco Bonardo [:mak] from comment #6)
> Also, I'd suggest to try by temporarily disabling the antivirus, even just
> for 10 minutes, to exclude its interaction.

Disabled antivirus - Still same issue.

NEW INFO:  Checked profile's bookmarkbackups folder.  All attempted saves are 0 byte files!
(In reply to Jay Pearce from comment #7)
> Created new profile - Problem is gone!

OK, so looks like you have some issue at the database level.

Would you mind trying to cleanup the database with this add-on?
https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/
2013-09-12 Ran Places Maintenance->Deep Check, ran Maintenance, ran Rebuild Indices.  No problems/corrections reported.

Same manual backup result:  0 byte file created then deleted.  Found in FF's bookmarkbackups\bookmarks-2013-09-12.json, 0 byte file created.  NOTE:  All auto-backups in FF's bookmarkbackups\ are 0 byte files!
I see. To be able to debug this issue, I need to test a copy of your bookmarks database.
So, if you are comfortable with that, you may send a copy of the places.sqlite file (found in your profile folder) to my e-mail address. Just don't attach it here in the bug, since it contains your private history data.
I can confirm the bug, there's something wrong in the database and the backups code stops there instead of skipping the broken entry.
Assignee: nobody → mak77
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Note possibly similar reports can be seen in the Mozilla *sumo* support forum. I mention this partly because if further information is required we may be able to ask in sumo threads.https://support.mozilla.org/en-US/questions/984450#answer-526868
Looks like the patch in bug 824433 has fixed this, I can properly export bookmarks from your database now.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Depends on: 824433
Resolution: --- → WORKSFORME
Duplicate of this bug: 982173
Marco,

Jay is still experiencing this problem and he opened up Bug 982173. I redirected him back to this bug and told him I would re-open. However I will leave the re-opening to someone else who has canconfirm permissions since I don't want to re-open a bug without probable cause.
Flags: needinfo?(mak77)
Did he use the latest Nightly/Aurora? I tried to export his database and didn't have any issues. So please just ensure you are using the latest version of Aurora or Nightly, from bug 982173 I see a Beta signature, this bug is NOT fixed in beta.
Flags: needinfo?(mak77)
Resolution: WORKSFORME → FIXED
Target Milestone: --- → Firefox 29
ehr, didn't mean to change resolution.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.