"JavaScript strict warning: chrome://browser/content/browser.js, line 5886: assignment to undeclared variable SocialStatus" warning in debug build startup output

RESOLVED FIXED in Firefox 26

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: dholbert)

Tracking

Trunk
Firefox 26
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Noticed this in some Jetpack test logs recently. Figured it was worth filing.

https://tbpl.mozilla.org/php/getParsedLog.php?id=27572876&tree=Mozilla-Inbound

JavaScript strict warning: chrome://browser/content/browser.js, line 5886: assignment to undeclared variable SocialStatus
(Reporter)

Updated

5 years ago
Duplicate of this bug: 914337
(Assignee)

Comment 2

5 years ago
Created attachment 801756 [details] [diff] [review]
fix: add "let" to declare the variable
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
Attachment #801756 - Flags: review?(mixedpuppy)
(Assignee)

Updated

5 years ago
Blocks: 891225
(Assignee)

Comment 3

5 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #0)
> Noticed this in some Jetpack test logs recently. Figured it was worth filing.

I think we hit this in all debug builds. I see it in my startup-spew of my local debug build -- it's the ~10th line of output on my system (intermixed with some "++DOMWINDOW" lines).
Summary: "JavaScript strict warning: chrome://browser/content/browser.js, line 5886: assignment to undeclared variable SocialStatus" warning in Jetpack logs → "JavaScript strict warning: chrome://browser/content/browser.js, line 5886: assignment to undeclared variable SocialStatus" warning in debug build startup output
(Assignee)

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86_64 → All
Version: unspecified → Trunk
Comment on attachment 801756 [details] [diff] [review]
fix: add "let" to declare the variable


:(

Hi Daniel,
Add SocialStatus to the let list at the top of browser-social.js (it needs to be global due to the button oncommand).  r=me with that.
Shane
Attachment #801756 - Flags: review?(mixedpuppy) → review+
(Assignee)

Comment 5

5 years ago
Created attachment 801807 [details] [diff] [review]
updated fix w/ review comment addressed

Gotcha. Thanks for the r+!  inbound is currently closed, so I'm posting the updated patch as checkin-needed.
Attachment #801807 - Flags: review+
Attachment #801807 - Flags: checkin?
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

5 years ago
Inbound's open again, so I landed:
 https://hg.mozilla.org/integration/mozilla-inbound/rev/a9ccc26e524b
Flags: in-testsuite-
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Attachment #801807 - Flags: checkin?
Duplicate of this bug: 914400
https://hg.mozilla.org/mozilla-central/rev/a9ccc26e524b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.