Closed Bug 914388 Opened 7 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Camera] Preview pictures appear zoomed in

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ckreinbring, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Description:
Taking a picture for a contact using the camera will cause the picture preview to appear zoomed in.  The actual picture appears properly on the contact and in the gallery.  A possible suspect is: "E/copybit(1772): copyBits failed (Invalid argument)"

Repro Steps:
1) Update Buri to Build ID: 20130909114657
2) Launch the Contacts app and create a contact if one does not exist.
3) Select a contact then tap the Edit button in the upper right corner.
4) Tap the picture space in the upper left corner and select Camera.
5) Take a picture and observe its appearance before and after the picture is taken.

Actual:
The picture preview appears to be a zoomed in version of the actual picture taken.

Expected:
The picture preview has the same appearance as the actual picture taken.

Environmental Variables
Occurs on Buri 1.2 mozilla RIL
Build ID: 20130909114657
Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
blocking-b2g: --- → koi?
Keywords: regression
QA Contact: nkot
regression range:

Build ID: 20130906040204 - Does NOT Reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Platform Version: 26.0a1

Build ID: 20130909114657 - Reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Platform Version: 26.0a1

*builds 09/05 - 09/06 are affected by bug 913418
 picture preview appears normally on 09/04 build
No longer blocks: b2g-central-dogfood
Summary: [B2G] [Buri] [1.2] [Contacts] Preview picture for contact appears zoomed in → [B2G] [Buri] [1.2] [Camera] Preview pictures appear zoomed in
Unable to reproduce on Buri 1.2 mozilla RIL.  The preview picture shows in the correct size and zoom level.  Resolving as Worksforme.

Build ID: 20130912040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/a98569f21abe
Gaia: 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
Platform Version: 26.0a1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.