Closed Bug 914894 Opened 6 years ago Closed 6 years ago

Android l10n repacks broken No rule to make target `/builds/slave/m-cen-and-l10n_1-0000000000000/build/mozilla-central/obj-l10n/mobile/android/base/locales/../../../../dist/bin/chrome/ar/locale/branding/brand.dtd', needed by `../res/values/strings.xml'

Categories

(Firefox Build System :: General, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla26

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

This only happens on the first repack. The subsequent ones don't fail.
The problem is that strings.xml is built once properly, and then rebuilt because all the other res/* directories are created, because strings.xml depends on them all. And when it is rebuilt that way, XPI_NAME is not set, and the build fails.
Susequent repacks work because the res/* directories are already there and are not changed, so strings.xml is not re-rebuilt.
Attachment #802666 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/c38b60b9063e
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.