All users were logged out of Bugzilla on October 13th, 2018

Android multilocale nightlies broken, "L10NBASEDIR not defined by configure. Stop"

RESOLVED FIXED in mozilla26

Status

--
critical
RESOLVED FIXED
5 years ago
8 months ago

People

(Reporter: philor, Assigned: glandium)

Tracking

Trunk
mozilla26
ARM
Android
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Regression range is the unwieldy http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ab5f29823236&tochange=3697f962bb7b

https://tbpl.mozilla.org/php/getParsedLog.php?id=27533731&tree=Mozilla-Central

07:31:04     INFO -  make[4]: Entering directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/base'
07:31:04     INFO -  make -C locales
07:31:04     INFO -  make[5]: Entering directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/base/locales'
07:31:04    ERROR -  Makefile:69: *** L10NBASEDIR not defined by configure.  Stop.
07:31:04     INFO -  make[5]: Leaving directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/base/locales'
07:31:04    ERROR -  make[4]: *** [res/values/strings.xml] Error 2
07:31:04     INFO -  make[4]: Leaving directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/base'
07:31:04    ERROR -  make[3]: *** [make-package-internal] Error 2
07:31:04     INFO -  make[3]: Leaving directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/installer'
07:31:04    ERROR -  make[2]: *** [make-package] Error 2
07:31:04     INFO -  make[2]: Leaving directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/installer'
07:31:04    ERROR -  make[1]: *** [default] Error 2
07:31:04     INFO -  make[1]: Leaving directory `/builds/slave/m-cen-and-ntly-000000000000000/build/obj-firefox/mobile/android/installer'
07:31:04     INFO -  make: *** [package] Error 2
07:31:04    ERROR - Return code: 2
07:31:04    FATAL - Halting on failure while running make package AB_CD=multi
07:31:04    FATAL - Running post_fatal callback...
07:31:04    FATAL - Exiting 2
(Assignee)

Comment 1

5 years ago
Could be related to bug 913134.
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla
Blocks: 913134
(Assignee)

Comment 2

5 years ago
Created attachment 801316 [details] [diff] [review]
Avoid recursing under mobile/android/base/locales when rebuilding gecko.ap_
Attachment #801316 - Flags: review?(ted)
Attachment #801316 - Flags: review?(khuey)
(Assignee)

Comment 3

5 years ago
Comment on attachment 801316 [details] [diff] [review]
Avoid recursing under mobile/android/base/locales when rebuilding gecko.ap_

For whoever comes first. I originally wanted to blow up mobile/android/base/locales, but i didn't want to risk more l10n breakage.
The core problem in this bug is that when rebuilding gecko.ap_ for multi locales, we're re-recursing in mobile/android/base/locales presumably because of the dependencies on directories which have changed because of the files added in them. Fortunately, whatever is getting the res/ directory to put in gecko.ap_ already ignores files whose name starts with a dot, so it doesn't add the .mkdir.done files.
Attachment #801316 - Flags: review?(gps)
Duplicate of this bug: 913987
Comment on attachment 801316 [details] [diff] [review]
Avoid recursing under mobile/android/base/locales when rebuilding gecko.ap_

Review of attachment 801316 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/Makefile.in
@@ +1369,5 @@
>  
> +$(call mkdir_deps,$(RES_DIRS)): $(subst res/,$(srcdir)/resources/,$(RESOURCES))
> +	$(RM) -r $(@D)
> +	$(NSINSTALL) -D $(@D)
> +	$(TOUCH) -t 198001030000 $@

This is pretty awful, but I guess it's not much worse than what we already have.
Attachment #801316 - Flags: review?(ted)
Attachment #801316 - Flags: review?(khuey)
Attachment #801316 - Flags: review?(gps)
Attachment #801316 - Flags: review+

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/24af5272b52f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(Assignee)

Updated

5 years ago
Depends on: 914894

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.