Closed Bug 914935 Opened 6 years ago Closed 6 years ago

pymake doesn't handle colons gracefully in includedep files

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla26

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

pymake considers that a colon followed by a slash or backslash is not to be treated as the usual target/dependencies separator. But it doesn't do that for includedep files.
But these files contain full windows paths, including the drive letter, which means the drive letter is considered a target, and everything that follows, dependencies.
Attachment #802718 - Flags: review?(gps) → review+
Comment on attachment 802718 [details] [diff] [review]
Fix pymake handling of colon in includedep files

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 852249
User impact if declined: Windows builds may fail after some classes of changes because dependencies are not fully defined.
Testing completed (on m-c, etc.): Landed on m-i today. Tested locally by avih.
Risk to taking this patch (and alternatives if risky): Should be low risk
String or IDL/UUID changes made by this patch: None
Attachment #802718 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/895784bef7fd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Duplicate of this bug: 912327
Blocks: 913880
(In reply to Mike Hommey [:glandium] from comment #3)
> User impact if declined: Windows builds may fail after some classes of
> changes because dependencies are not fully defined.

This has been around for a while - isn't the risk of this breaking something in the 25 timeframe very unlikely since it'll already be frozen? And wouldn't we know if it broke?
Comment on attachment 802718 [details] [diff] [review]
Fix pymake handling of colon in includedep files

26 is on Aurora now and from Alex's comment it looks unlikely this will get uplift approval for Beta but if there's a significant reward please re-nominate for approval-beta
Attachment #802718 - Flags: approval-mozilla-aurora?
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.