The Add Dictionary option should also be disabled when the Check Spelling one is disabled

RESOLVED DUPLICATE of bug 908570

Status

()

RESOLVED DUPLICATE of bug 908570
5 years ago
5 years ago

People

(Reporter: ioana_damy, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 802954 [details]
testcase.html

Reproducible on Firefox 24, 25 and 26.
Regressed by the fix for bug 905176.

STR:
1. Load the attached testcase in the browser.
2. Right-click the contenteditable on the page.

Expected Results:
Since the Check Spelling option is disabled when spellcheck="false" (checking cannot be forced), the Add Dictionary option should also be disabled.

Actual Results:
The Add Dictionary option is enabled. It gives the user the impression that adding a dictionary will enable spell checking, since it makes no sense that it would be there without being of use.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908570
You need to log in before you can comment on or make changes to this bug.