Closed Bug 915293 Opened 7 years ago Closed 7 years ago

[B2G] [Buri] [1.2] [Gallery] Device crashes when using the editing tools, especially cropping an existing picture

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 901559

People

(Reporter: ckreinbring, Unassigned)

References

Details

Attachments

(1 file)

Description:
Attempting to crop a Gallery picture causes the device to crash.  Using the other editing tools can also cause crashes, but they require multiple uses.

Repro Steps:
1) Updated Buri to Build ID: 20130911040201
2) Launch the Gallery app.
3) Tap a picture then the Edit icon.
4) Tap the Crop tab and set the cropping border.
5) Tap the Done icon in the upper right corner and observe the device's reaction.

Actual:
The device crashes.

Expected:
The user is returned to the gallery grid view with the cropped version of the picture appearing on the top row, left side.

Environmental Variables
Occure on Buri 1.2 mozilla RIL
Build ID: 20130911040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/f9e8e8ce552c
Gaia: ebbb325958c66c3e68e1f190472d5f6e9076d83a
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
Crash ID: bp-acd58da8-4a56-4bb2-800a-8509a2130911
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901559
Does not repro to the full extent on Buri 1.2 mozilla RIL.  The device no longer crashes after using an editing tool, but the Done icon will sometimes not respond after using the editing tools.

Build ID: 20130912040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/a98569f21abe
Gaia: 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
Platform Version: 26.0a1
See Also: → 915876
You need to log in before you can comment on or make changes to this bug.