Closed Bug 915876 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Gallery] Attempts to edit pictures do not get saved

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, firefox27 affected, b2g-v1.2 affected)

RESOLVED WORKSFORME
1.3 Sprint 4 - 11/8
blocking-b2g koi+
Tracking Status
firefox27 --- affected
b2g-v1.2 --- affected

People

(Reporter: ckreinbring, Assigned: sotaro, NeedInfo)

References

Details

(Keywords: regression, Whiteboard: [burirun1][fromAutomation][xfail], burirun3)

Attachments

(3 files)

Description:
Making changes to a picture and attempting to save does not save the changed picture.

Repro Steps:
1) Update Buri to Build ID: 20130912040201
2) Launch the Gallery app.
3) Select a picture then tap the Edit icon.
4) Make a change to the picture then tap the Done icon.
5) Observe the reaction on the screen.

Actual:
Done icon fades and becomes unselectable, but the changed picture is not saved.

Expected:
The user is returned to the grid view with the changed picture added to the upper left corner.

Environmental Variables
Occurs on the Buri 1.2 mozilla RIL
Build ID: 20130912040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/a98569f21abe
Gaia: 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
Platform Version: 26.0a1

Notes:
Repro frequency: 85%
See attached logcat logs
See Also: → 915293
QA Contact: laliaga
No longer blocks: b2g-central-dogfood
blocking-b2g: --- → koi?
Keywords: regression
Tested as far back as 6/21 (our earliest) on Buri. Unable to save edited photos.

- Broken 1.2 -
Environmental Variables
Build ID: 20130621031231
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ba8c86f1a56
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Platform Version: 24.0a1

Tested on a Leo device 1.1 and it's working. Able to save edited photos.

- Working 1.1 -
Environmental Variables
Build ID: 20130909041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/796d0adce82b
Gaia: 6324c3b047aabee83ec7419803224e8edf07db7c
Platform Version: 18.1
Adding needs info for Lucas - we need the last time this worked in a build, and the first build it was broken in.
Flags: needinfo?(laliaga)
(In reply to Marcia Knous [:marcia] from comment #2)
> Adding needs info for Lucas - we need the last time this worked in a build,
> and the first build it was broken in.

I think what Lucas is saying here is that he's gone far enough back to confirm that the regression is occurring all the way back in June on central. Do we even have builds to go farther back than this?

FWIW - I think regression windows are really only going to get their value if it's within a 3 - 4 month timeframe. Any farther than that will introduce too many changes, so we'll likely need a forward fix as a result.
Whiteboard: burirun1
Flags: needinfo?(laliaga) → needinfo?(mozillamarcia.knous)
I was asked to retest this on 1.2 for triage team. On Buri using:

Gaia   88e73da95f1c550f2fb0572480a40c989d37c997
SourceStamp 46b216260c1d
BuildID 20130920004004
Version 26.0a2

I am unable to edit a picture at all, because whenever I made the change and tap the "check" button, nothing happens. See attached logcat there are numerous "unknown deliver target" messages. This affects the latest Mozilla Central Build as well.
Flags: needinfo?(mozillamarcia.knous)
From attachment 808055 [details], it seems to fail to create GLContext because of out of pmem

------------------------------------------------
E/msm7627a.gralloc(141): gralloc failed err=Out of memory
W/GraphicBufferAllocator(141): alloc(1200, 1600, 1, 00000300, ...) failed -12 (Out of memory)
E/GeckoConsole(495): [JavaScript Warning: "Error: WebGL: Can't get a usable WebGL context" {file: "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1151}]
E/GeckoConsole(495): [JavaScript Error: "TypeError: gl is null" {file: "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1154}]
Current v1.2 and master's WebGL does not support memory fallback during out of pmem. Then If this happens WebGL context creation just fail. There seems two choices in Bug 905882 comment 12 to handle this condition. Need to make clear and decide choose which one.
Assignee: nobody → sotaro.ikeda.g
Based on comment #4 with the retest results saying edit is broken and last triage discussion, making this a koi+
blocking-b2g: koi? → koi+
Both attachment 808055 [details] and attachment 804009 [details] have following log. From the log, it became clear that "fallback during out of pmem" were disabled. 

> E/memalloc(154): /dev/pmem: No more pmem available
> E/msm7627a.gralloc(154): gralloc failed err=Out of memory
> W/GraphicBufferAllocator(154): alloc(1000, 634, 1, 00000300, ...) failed -12 (Out of memory)
I locally created the following ROM. By using the ROM, edited picture save seems always succeeded on my master hamachi.
 - Enable out of pmem fallback by reverting Bug905784.
 - Disable HwComposer to prevent rendering problem.

From this, if b2g handles 'out of pmem' correctly, this problem seems to be solved.
Right now, Bug 905882 seems most graceful fallback.
Depends on: 905882
Following the STRs in Comment 0 on Mozilla Build Master/m-c the actual results were reproduced - Done icon fades and becomes unselectable, but the changed picture is not saved. This is the logcat for the below 

Environmental Variables
Gaia   959ac2f692d85072ffdc3d16a041b5bf4735ae59
Gecko aa986b6ce882
BuildID 20131010040202
Version 27.0a1
Whiteboard: burirun1 → [burirun1][fromAutomation]
Blocks: 801898
Blocks: 925854
No longer blocks: 801898
Whiteboard: [burirun1][fromAutomation] → [burirun1][fromAutomation][xfail]
Hema,

What is the ETA for this koi+ issue to be fixed?

Are we dependent on 905882 for 915876 to be resolved?
Flags: needinfo?(hkoka)
Waiting on Bug 905882 to land, to help here.
Flags: needinfo?(hkoka)
Blocks: 891030
QA Wanted - dependency is fixed now. Can we retest?
Keywords: qawanted
This issue reproduces on Buri 1.2 Build ID: 20131101004000

Gaia   e717aec947571f5daf923c040a82f9f0719bb526
SourceStamp 54de309e18a9
BuildID 20131101004000
Version 26.0

This issue also reproduces on Buri 1.3 Build ID: 20131101040203

Gaia   ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
SourceStamp abe6790a5dd8
BuildID 20131101040203
Version 28.0a1
Keywords: qawanted
Depends on: 934602
Whiteboard: [burirun1][fromAutomation][xfail] → [burirun1][fromAutomation][xfail], burirun3
Target Milestone: --- → 1.3 Sprint 4 - 11/8
Past Target Milestone and still repros on 1.2

Environmental Variables:
Device: Buri 1.2 mozRIL
BuildID: 20131111004004
Gaia: 670b2c8329bca6f142939185be71274166d82bb8
Gecko: 1ac147e4e2f0
Version: 26.0
Firmware Version: 20131104
Fixed on OEM version.

Gaia   2ef9bc3c7a6de228b63e6ba3613eb0c0dd639c59
BuildID 20131105151351
Version 26.0a2
1.2 Buri

Will retest on our own gecko/gaia on top of OEM build after finishing further OEM testing
Fixed on 
Gaia:     377eb71506d8790d3c3280d82ac007ff4525b7e0
Gecko:    c15f5d7e0d7ebff5f8edef0745f144cd1552e34c
BuildID   20131112123250
Version   28.0a1
Base Build : US_V1.2_20131111.cfg
Buri
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 938125
QA Verified, thanks!
Status: RESOLVED → VERIFIED
The issue is not fixed on the hamachi yet. Tried on:

Gaia:     67866e82379e751646aa5f0fd6a7a4268e9529c1
Gecko:    http://hg.mozilla.org/mozilla-central/rev/597287004ff5
BuildID   20131120062258
Version   28.0a1

Edited picture doesn't get saved and I get the following log messages:

E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
W/GraphicBufferAllocator(  140): alloc(1024, 1024, 1, 00000300, ...) failed -12 (Out of memory)
E/GeckoConsole(  732): [JavaScript Warning: "Error: WebGL: Can't get a usable WebGL context" {file: "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1306}]

Helix works as expected on:

Gaia:     c26480b22ce28c812c347290dd4bad090d83db6f
Gecko:    http://hg.mozilla.org/mozilla-central/rev/597287004ff5
BuildID   20131120062258
Version   28.0a1
Flags: needinfo?(ikeda.sohtaroh)
(In reply to Diego Marcos from comment #21)
> The issue is not fixed on the hamachi yet. Tried on:
> 
> Gaia:     67866e82379e751646aa5f0fd6a7a4268e9529c1
> Gecko:    http://hg.mozilla.org/mozilla-central/rev/597287004ff5
> BuildID   20131120062258
> Version   28.0a1
> 
> Edited picture doesn't get saved and I get the following log messages:
> 
> E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
> W/GraphicBufferAllocator(  140): alloc(1024, 1024, 1, 00000300, ...) failed
> -12 (Out of memory)
> E/GeckoConsole(  732): [JavaScript Warning: "Error: WebGL: Can't get a
> usable WebGL context" {file:
> "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1306}]
> 
> Helix works as expected on:
> 
> Gaia:     c26480b22ce28c812c347290dd4bad090d83db6f
> Gecko:    http://hg.mozilla.org/mozilla-central/rev/597287004ff5
> BuildID   20131120062258
> Version   28.0a1

What base image are you using?
How can I tell the base image?
Diego, I think you're still on 1.1 if you haven't flashed the device with the windows flashing tool.

You will want to flash with the v1.2_20131115.cfg build.
To note :
adb shell cat /system/build.prop | grep "ro.build.date"

The v1.2_20131115 build will have : 
ro.build.date=Thu Nov 14 10:58:33 CST 2013
ro.build.date.utc=1384397913

Diego checked with me and we verified that he was on an older base build.
(In reply to Diego Marcos from comment #21)
> The issue is not fixed on the hamachi yet. Tried on:
> 
> Gaia:     67866e82379e751646aa5f0fd6a7a4268e9529c1
> Gecko:    http://hg.mozilla.org/mozilla-central/rev/597287004ff5
> BuildID   20131120062258
> Version   28.0a1
> 
> Edited picture doesn't get saved and I get the following log messages:
> 
> E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
> W/GraphicBufferAllocator(  140): alloc(1024, 1024, 1, 00000300, ...) failed
> -12 (Out of memory)
> E/GeckoConsole(  732): [JavaScript Warning: "Error: WebGL: Can't get a
> usable WebGL context" {file:
> "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1306}]
> 

This log says pmem fallback did not work on the ROM. If the fallback happens the following log should be there.

> E/memalloc(137): /dev/pmem: No more pmem available
> W/memalloc(137): Falling back to ashmem
QA Contact: laliaga
I flashed my hamachi with the latest OEM build.

I still cannot save edited images on gallery. Versions installed:

Gaia      0659f16b9790b1cf9eba4d80743fcc774d2ffe3a
Gecko     http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/af2c7ebb5967
BuildID   20131205004003
Version   26.0
ro.build.version.incremental=eng.archermind.20131114.105818

Steps to reproduce:

1. Open Camera
2. Take Picture
3. Go to Gallery
4. Edit and save the picture multiple. Most of the times the gallery is killed at the 2nd attempt.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Diego Marcos from comment #27)
> I flashed my hamachi with the latest OEM build.
> 
> I still cannot save edited images on gallery. Versions installed:
> 
> Gaia      0659f16b9790b1cf9eba4d80743fcc774d2ffe3a
> Gecko     http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/af2c7ebb5967
> BuildID   20131205004003
> Version   26.0
> ro.build.version.incremental=eng.archermind.20131114.105818
> 
> Steps to reproduce:
> 
> 1. Open Camera
> 2. Take Picture
> 3. Go to Gallery
> 4. Edit and save the picture multiple. Most of the times the gallery is
> killed at the 2nd attempt.

There's other bugs open for tracking this. See bug 939962, bug 941160, and bug 945774. They are all focusing on the Skia GL specific issue involved here.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.