Crash loading pages - N610 [@ HTMLContentSink::ProcessMETATag]

VERIFIED FIXED

Status

()

Core
HTML: Parser
--
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Dave Barrowman, Assigned: Gagan)

Tracking

({crash, regression, topcrash})

Trunk
x86
Windows 98
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+ fixed/verified on branch, crash signature, URL)

(Reporter)

Description

17 years ago
Build: 20010719, Windows 98

When I try to open the sidebar tab, the product crashes.  

Here is the talkback info:

Incident ID 33103623
Stack Signature HTMLContentSink::ProcessMETATag 151e3f79
Bug ID
Trigger Time 2001-07-19 14:16:59
User Comments phonebook tab
Build ID 2001071905
Product ID Netscape6.10
Platform ID Win32
Stack Trace
HTMLContentSink::ProcessMETATag
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 4525]
HTMLContentSink::AddLeaf
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3390]
CNavDTD::AddLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3796]
CNavDTD::AddHeadLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3855]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1750]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 924]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 549]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2222]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2086]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2696]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 236]
nsStreamListenerTee::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 57]
nsHttpChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2227]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 188]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00688b5e
(Reporter)

Comment 1

17 years ago
Another talkback report:

Incident ID 33103416
Stack Signature HTMLContentSink::ProcessMETATag 151e3f79
Bug ID
Trigger Time 2001-07-19 14:12:10
User Comments Crash loading Phonebook Sidebar tab
Build ID 2001071905
Product ID   Netscape6.10
Platform ID Win32
Stack Trace
HTMLContentSink::ProcessMETATag
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 4525]
HTMLContentSink::AddLeaf
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3390]
CNavDTD::AddLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3796]
CNavDTD::AddHeadLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3855]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1750]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 924]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 549]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2222]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2086]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2696]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 236]
nsStreamListenerTee::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 57]
nsHttpChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2227]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 188]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00688b5e 

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Can you please post the url and also the place where i can add this tab.
thanks

Comment 3

17 years ago
matt: 
http://rocknroll/users/michaell/publish/addpanel/addpanel.html

Perhaps this bug needs to be in bugscape as these are Netscape internal links;
however, the bug itself probably is in open source code and the test case we
have here is internal.

Comment 4

17 years ago
sujay - can you go back a week or so to see if this particular sidebar tab was
working at that time?
Keywords: crash

Comment 5

17 years ago
I crash consistently when I attempt to access this tab

Comment 6

17 years ago
This isn't sidebar-specific; just go to
http://rocknroll/users/michaell/publish/addpanel/phonebook.html and you'll crash
too. --> parser

Assignee: matt → harishd
Component: Sidebar → Parser
QA Contact: sujay → bsharma

Comment 7

17 years ago
I tried adding the sidebar tab in a build from one week ago 7/12 build.
It worked fine.

Updated

17 years ago
Severity: normal → critical

Updated

17 years ago
Keywords: regression

Comment 8

17 years ago
I just came across a crash loading popularcategories.com with this same stack
trace (it obviously worked in pr1 since a user reported a problem with the page
layout).

Harish, can you look into this today?
Summary: product crashes when opening phonebook sidebar tab → Crash @ HTMLContentSink::ProcessMETATag

Comment 9

17 years ago
sure, will take a look right away.
Status: NEW → ASSIGNED
Summary: Crash @ HTMLContentSink::ProcessMETATag → product crashes when opening phonebook sidebar tab

Comment 10

17 years ago
Gagan, could this be related to your fix for bug 90288?

Sujay, can you try a branch build from the 17th or 18th?
Summary: product crashes when opening phonebook sidebar tab → Crash loading pages @ HTMLContentSink::ProcessMETATag

Comment 11

17 years ago
Blake: I bet it's related to gagan's change. I have a build without his change
and it doesn't crash.

Comment 12

17 years ago
Yep -- we also have lots of crashes with this trace that started just today:

http://climate/reports/searchstacksignature.cfm?stacksig=HTMLContentSink%3A%3AProcessMETATag
(Assignee)

Comment 13

17 years ago
taking over... my bad...
Assignee: harishd → gagan
Status: ASSIGNED → NEW

Comment 14

17 years ago
installed 7/18 branch build on windows..

visited both URLs listed in this bug report:

http://www.popularcategories.com
http://rocknroll/users/michaell/publish/addpanel/phonebook.html

no crash at either URLs.

Comment 15

17 years ago
based on the patch gagan emailed me, sr=

Comment 16

17 years ago
Verified on 2001-07-17-branch build on WinNT for both above mentioned url's and
there is no crash.

Changing status to WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 17

17 years ago
r=harishd. But we need to figure out why mParser was null.
(Assignee)

Comment 18

17 years ago
nope its not a WFM... reopening applied the following patch that dougt and 
harishd reviewed--

-              if (NS_SUCCEEDED(mParser->GetChannel(getter_AddRefs(channel))) &&
-                      channel) {
+              if (mParser &&
+                  NS_SUCCEEDED(mParser->GetChannel(getter_AddRefs(channel))))
+      
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 19

17 years ago
fix checked in to the branch.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

17 years ago
Even though the crash is now gone... I am concerned as to why the mParser came 
up null. That should never have happened (according to harishd) investigating 
this may bring out some interesting things...

Comment 21

17 years ago
Verified on 2001-07-19-branch build on WinNT.

I created a new profile.
When loading both above url as 'open link in new window' the url's loads fine.

But, when I directly click on them then url http://www.popularcategories.com
loads fine but url
http://rocknroll/users/michaell/publish/addpanel/phonebook.html crashes.

Comment 22

17 years ago
I figured out the real reason why mParser was null. 

The document contains META tag with charset=utf-8. In the process of reloading
the  the document, with utf-8 charset, we terminate the current document load (
hence  released the parser ). However, unwinding off the stack we failed to
check if the current document was still valid or not and proceeded with
processing the META tag. Will file a bug on myself on this issue.

Comment 23

17 years ago
*** Bug 91556 has been marked as a duplicate of this bug. ***
*** Bug 91582 has been marked as a duplicate of this bug. ***

Comment 25

17 years ago
*** Bug 91597 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
Adding N610 and topcrash keyword for future reference.  This regression made the
crash the #1 topcrasher on today's N610 branch Talkback topcrash reports.
Keywords: topcrash
Summary: Crash loading pages @ HTMLContentSink::ProcessMETATag → Crash loading pages - N610 [@ HTMLContentSink::ProcessMETATag]

Comment 27

17 years ago
gagan - was this fixed to the trunk too?  

bindu - pls go through the dup bugs and try those URLs on the branch build to
make sure loading ok.  Thanks.
(Assignee)

Comment 28

17 years ago
this wouldn't have occured on the trunk since my changes (from which this 
regressed) were only for the branch.

Comment 29

17 years ago
Here is the result of these url's and the dup bugs url's:

Verified on 2001-07-19-branch build on WinNT.

Bug 91538: url http://www.popularcategories.com loads fine but url
http://rocknroll/users/michaell/publish/addpanel/phonebook.html crashes.

Bug 91556: url http://www.va-oakland.com/caproperty.html loads fine.

Bug 91582: url http://www.jp.aol.com/ crashes.

Bug 91597: url http://babel/tests/Browser/WinIntegration/WinInteg_test.html
loads fine.

Comment 30

17 years ago
These all loaded fine for me on 2001-07-20-branch build on Win98.

Comment 31

17 years ago
putting whiteboard back to PDT+ so I can tell this went on branch in my uber-query.
Whiteboard: PDT+ fixed on branch

Comment 32

17 years ago
with the 2001097-21-nn-0.9.2 branch candidate builds, none of the URLs noted
above by bsharma crash the browser on mac, linux or win32. [If we were crashing
why didn't we reopen this bug?]
Status: RESOLVED → VERIFIED
Whiteboard: PDT+ fixed on branch → PDT+ fixed/verified on branch

Comment 33

17 years ago
also verified the phonebook tab in sidebar. that doesn't crash anymore
in 7/23 branch build.

Comment 34

17 years ago
*** Bug 91565 has been marked as a duplicate of this bug. ***
Crash Signature: [@ HTMLContentSink::ProcessMETATag]
You need to log in before you can comment on or make changes to this bug.