[prod] /query/ Crash signatures in search results do not link to reports

RESOLVED FIXED in 60

Status

--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mbrandt, Assigned: peterbe)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [prod])

(Reporter)

Description

5 years ago
Steps to reproduce:
1. goto https://crash-stats.mozilla.com/query/?product=Firefox&version=Firefox%3A26.0a1&platform=mac&range_value=1&range_unit=weeks&date=09%2F11%2F2013+22%3A00%3A00&query_search=signature&query_type=contains&query=&reason=&release_channels=&build_id=&process_type=any&hang_type=any
2. click on any crash signature

Expected:
When the signature is clicked, the proper report is opened

Actual:
A click event is not allowed, the user is unable to open the report
Using Firebug I see that some script seems to not be loading:

<script src="/static/CACHE/js/2f8bacb271e4.js" type="text/javascript">
undefined
</script>
<script src="/static/browserid/browserid.js" type="text/javascript">
undefined
</script>
<script src="https://browserid.org/include.js" type="text/javascript">
<script type="text/javascript">
var SEARCH_FORM_PARAMS = {"products": ["Firefox"], "versions": ["Firefox:26.0a1"]};....
</script>
<script src="/static/CACHE/js/67e83a83cafc.js" type="text/javascript">
undefined
</script>
Assignee: nobody → schalk.neethling.bugs
(Reporter)

Comment 2

5 years ago
Bumping priority on bug - this is hurting our product QA team.
Severity: normal → major
So I can see the above on production but at the same time I have found that changing the version (this is the only thing I tested) and then click 'filter results' never returns any results. It seems there is also not ajax calls being triggered and the Net tab shows no other networks activity.

@see http://screencast.com/t/uU4vZcMh7A0R
Bad thing, I cannot replicate this locally. All of the above works fine.
(Reporter)

Updated

5 years ago
Target Milestone: --- → 60
(In reply to Matt Brandt [:mbrandt] from comment #2)
> Bumping priority on bug - this is hurting our product QA team.

You still experiencing this?
(Reporter)

Comment 6

5 years ago
(In reply to Schalk Neethling [:espressive] from comment #5)
> You still experiencing this?

This is still present on production - unfortunately the behavior was never present on dev or stage; only prod.

Steps to repro in comment 0 still illicit the bug.
(Assignee)

Comment 7

5 years ago
FYI, I run the same query in my laptop with the same compressed javascript and it is NOT reproduce-able.
(Assignee)

Comment 8

5 years ago
I downloaded 67e83a83cafc.js and 2f8bacb271e4.js and confirmed that they are equal on my system as that of prod. Still not reproduce-able on my system. 

Also, it does not matter if I'm signed in or not. Signed in or not, it works flawlessly on my system.
(Assignee)

Comment 9

5 years ago
It's because of this
https://bugzilla.mozilla.org/show_bug.cgi?id=522515 
Cryptic. I know. Check out the summary of that bug.
Assignee: schalk.neethling.bugs → peterbe
Status: NEW → ASSIGNED

Comment 11

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/879a58709b4148b4550d9d1157a683abed09aa81
fixes bug 915430 - /query/ signature links in search results do not work, r=espressive

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.