Create a long-term graph of crash rates

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
[I'm filing this in the Socorro product for now, but it might actually belong in a metrics component or such, depending on who will work on it.]

To see how the stability program is doing and how our product stability evolves, and to make that visible to both the stability group and management, we should have a long-term graph (over at least a year or two) of crash rates.

For the first iteration we should have this for the Firefox release channel, as a stacked area graph with series for browser crashes, plugin crashes and plugin hangs (for now - content crashes may be added later but we don't have those yet).

We already have this data in Socorro (we are using it for the front page graph there), it's just a matter of getting it out of the database and creating the graph.


One thing to think about there though is how we can smoothen out the variations we get at the start of every release, as we want an ongoing graph over a longer term. We could do the whole release channel, the recent two releases, all releases within the last x weeks (8? 12?) or something convoluted like "add up recent releases until we cross x% of uptake on the channel" (50%? 60%? 75%?). Some help and ideas there would be appreciated.


Once we have this for Firefox release, I'd like to see it for mobile ("FennecAndroid") and also for the beta channel as well.
(Reporter)

Comment 1

5 years ago
One things we should put on this graph as well, right away or as a followup, is this note from the stability week:
-----------------------------
Annotate/show events like Firefox or MS releases on the crash charts? SUMO already has the ability to note "events" on their graphs. They use it for releases as well. Maybe we can steal or learn.
-----------------------------
(Reporter)

Updated

5 years ago
Depends on: 933056
(Reporter)

Updated

5 years ago
Duplicate of this bug: 852517
(Reporter)

Comment 3

5 years ago
I have gathered some data for this recently and made some graphs like this for myself. This showed me well where the value of this is and I'm looking forward to having this is a dynamic and better accessible fashion.
(Reporter)

Comment 4

4 years ago
FWIW, I ended up fixing this myself as well, as I couldn't wait for it and this seems to not be of high priority to anyone else. See https://crash-analysis.mozilla.com/rkaiser/crash-report-tools/longtermgraph/ for my current solution.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.