Closed Bug 915522 Opened 6 years ago Closed 6 years ago

VS2013 support for NSPR

Categories

(NSPR :: NSPR, defect, P1)

x86
Windows 8
defect

Tracking

(Not tracked)

RESOLVED FIXED
4.10.2

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

Attachments

(1 file, 2 obsolete files)

When using parallel build, VS2013 cause the following error.  So we should add -FS when 2013+.

fatal error C1041: cannot open program database 'generated.pdb'; if multiple CL.EXE write to the same .PDB file, please use /FS


VS2013 has new option /Gw (http://blogs.msdn.com/b/vcblog/archive/2013/09/11/introducing-gw-compiler-switch.aspx).  We should use this when PGO.
Attached patch Fix for VS2013 (obsolete) — Splinter Review
Attachment #803514 - Flags: review?(wtc)
Comment on attachment 803514 [details] [diff] [review]
Fix for VS2013

Review of attachment 803514 [details] [diff] [review]:
-----------------------------------------------------------------

r=wtc.

::: configure.in
@@ +1955,5 @@
>          PROFILE_GEN_LDFLAGS="-LTCG:PGINSTRUMENT"
>          PROFILE_USE_CFLAGS="-GL -wd4624 -wd4952"
>          PROFILE_USE_LDFLAGS="-LTCG:PGUPDATE"
>  
> +        if test "$MSC_VER" -ge "1800"; then

Can you add a comment here to note this is Visual Studio 2013?

In the bug report, could you provide a link to the documentation of the /FS flag?

Thanks.
Attachment #803514 - Flags: review?(wtc) → review+
(In reply to Wan-Teh Chang from comment #2)
> In the bug report, could you provide a link to the documentation of the /FS
> flag?

No document on Web site yet.  After releasing VS2013 RTM, documents will be published.
Attached patch for check-in (obsolete) — Splinter Review
wtc, could you land this?  I have no permission.

$ hg push
pushing to ssh://hg.mozilla.org/projects/nspr/
Enter passphrase for key '/c/Users/mkato/.ssh/mozilla.id_dsa':
searching for changes
remote: abort: could not lock repository /repo/hg/mozilla/projects/nspr/: Permis
sion denied
abort: unexpected response: empty string
Keywords: checkin-needed
Duplicate of this bug: 918158
m_kato: yes, I will check this in.
Assignee: wtc → m_kato
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → 4.10.2
Thank you for catching my duplicate! I did not see this bug because it was not connected to the master bug 914596. If you know of any other VC12 issues, can you please mark them as blocking bug 914596? Thanks!
Blocks: VC12
Checkin ping :)
Flags: needinfo?(wtc)
I edited the comments and checked this in. Thanks.

https://hg.mozilla.org/projects/nspr/rev/d968016a6cf6
Attachment #803514 - Attachment is obsolete: true
Attachment #804204 - Attachment is obsolete: true
Attachment #810189 - Flags: checked-in+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(wtc)
Keywords: checkin-needed
Resolution: --- → FIXED
Is there a bug on file for us to get the next NSPR code drop?
Comment on attachment 810189 [details] [diff] [review]
Fix for VS2013, v3, by Makoto Kato

Review of attachment 810189 [details] [diff] [review]:
-----------------------------------------------------------------

Patch pushed to mozilla-inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b333c2cb538
You need to log in before you can comment on or make changes to this bug.