nsprpub needs -FS option for parallel build on VS2013

RESOLVED DUPLICATE of bug 915522

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 915522
4 years ago
4 years ago

People

(Reporter: dmajor (offline), Unassigned)

Tracking

Trunk
x86
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #915973 +++

When using VS2013, the following error occurs with make -j2

fatal error C1041: cannot open program database 'generated.pdb'; if multiple CL.EXE write to the same .PDB file, please use /FS

---

The patch for bug 915973 did not include the nsprpub folder
(Reporter)

Comment 1

4 years ago
Created attachment 807004 [details] [diff] [review]
Copy the -FS flag fix to nsprpub

Copied the fix to nsprpub/configure.in and ran autoconf
Had to use _CC_MAJOR_VERSION since we don't have _CC_SUITE here
Attachment #807004 - Flags: review?(ted)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915522
(Reporter)

Comment 3

4 years ago
Comment on attachment 807004 [details] [diff] [review]
Copy the -FS flag fix to nsprpub

Dupe, not needed
Attachment #807004 - Flags: review?(ted)
You need to log in before you can comment on or make changes to this bug.