Don't use TEXTURE_DEALLOCATE_HOST with canvases and deprecated texture clients

RESOLVED FIXED in Firefox 25

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nrc, Assigned: nrc)

Tracking

Trunk
mozilla26
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25+ fixed, firefox26+ fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Or we leak all over the place.
(Assignee)

Comment 1

5 years ago
Created attachment 804139 [details] [diff] [review]
patch
Attachment #804139 - Flags: review?(matt.woodrow)
(Assignee)

Updated

5 years ago
status-firefox25: --- → affected
status-firefox26: --- → affected
tracking-firefox26: --- → ?
Attachment #804139 - Flags: review?(matt.woodrow) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 804139 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 900133
User impact if declined: we will leak the texture backing every canvas we create on Android and Windows OMTC (the latter is not yet a supported platform).
Testing completed (on m-c, etc.): I can leave this for a few days on m-c, but I would like to get it on Aurora before the uplift.
Risk to taking this patch (and alternatives if risky): Low risk - restoring previous behaviour. No alternatives.
String or IDL/UUID changes made by this patch: None
Attachment #804139 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ae16eceedbbc
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
status-firefox24: --- → unaffected
tracking-firefox25: --- → +
tracking-firefox26: ? → +
status-firefox26: affected → fixed
Attachment #804139 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.