[B2G] [Leo] [Marketplace] Packaged apps don't launch properly, showing a directory and files

RESOLVED WORKSFORME

Status

Core Graveyard
DOM: Apps
RESOLVED WORKSFORME
4 years ago
28 days ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

({regression})

Trunk
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 804706 [details]
Log of failed packaged app launch

Description:
A packaged app downloaded from the Marketplace does not launch properly, instead showing a directory page with a list of files.

Repro Steps:
1) Update Buri to Build ID: 20130913041203
2) Launch the Marketplace app.
3) Find and download a packaged app.
4) Once the app is installed, launch it and observe the page that loads.

Actual:
The app does not launch properly, instead showing a directory and files.

Expected:
The app launches with no errors.

Environmental Variables
Occurs on Leo 1.1 commercial RIL
Build ID: 20130913041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/091fcf40d427
Gaia: f7afca06d02ee34fcd82eb0020eb2162e5045ee7
Platform Version: 18.1
RIL Version: 01.01.00.019.222 

Notes:
Repro frequency: 10%
See attached screenshot and logcat logs
(Reporter)

Updated

4 years ago
See Also: → bug 912149
(Reporter)

Comment 1

4 years ago
Created attachment 804709 [details]
Screenshot of failed packaged app launch
If this is reproducing even at 10%, this is really bad. We'll get numerous support call requests about users apps failing to launch. Can you provide example apps you reproduced this with?

I'll try reproducing this as well.
Component: Gaia::System → DOM: Apps
Keywords: regression
Product: Boot2Gecko → Core
Version: unspecified → Trunk

Updated

4 years ago
blocking-b2g: --- → leo?

Updated

4 years ago
QA Contact: sparsons
(Reporter)

Comment 3

4 years ago
I've had it happen with Captain Smash, Entanglement, and QA Code Scanner.  But even these apps won't necessarily repro the bug.

Also, the device in the description should be Leo instead of Buri.

Comment 4

4 years ago
Unable to reproduce on the Leo device on the 1.1 comm and moz RIL Build ID: 20130917041200

Environmental Variables
Build ID: 20130917041200
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/b459ac3ebe24
Gaia: 862b5761825e010e3cc5968c096377e1ea54bbf2
Platform Version: 18.1
RIL Version: 01.01.00.019.222 

Directory and files do not appear when launch applications downloaded from the Marketplace.
Keywords: regressionwindow-wanted
ckreinbring - can you retest? If you can reproduce, sync up with Sarah to show her what you are seeing.
blocking-b2g: leo? → ---
Flags: needinfo?(ckreinbring)
(Reporter)

Comment 6

4 years ago
I am also unable to repro on the same Leo build.  I downloaded over 20 packaged app, and all of them opened correctly.

Resolving as Worksforme.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ckreinbring)
Resolution: --- → WORKSFORME

Updated

28 days ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.