Disabling the Social API should remove the Services tab in about:addons

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED WONTFIX
5 years ago
5 months ago

People

(Reporter: der_tuxman, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140113])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20130911 Firefox/24.0 PaleMoon/24.0 (Nightly/Aurora)
Build ID: 20130911003217

Steps to reproduce:

I changed the social.enabled prefs setting to false.


Actual results:

The Social API was disabled, the Services tab in about:addons still remains visible for no obvious reason - it makes no sense anyway when social.enabled is false.


Expected results:

The Services tab should disappear.

Comment 1

4 years ago
Thanks for your report and sorry for answering so late. Can you still reproduce this bug?
Component: Untriaged → SocialAPI
Flags: needinfo?(der_tuxman)

Updated

4 years ago
Whiteboard: [bugday-20140113]
(Reporter)

Comment 2

4 years ago
Yes, Firefox beta still has this issue.
Flags: needinfo?(der_tuxman)

Updated

4 years ago
OS: Windows 7 → All
Hardware: x86 → All
Version: 24 Branch → Trunk

Comment 3

4 years ago
The tab is not shown here. Have you installed an extension before?
Flags: needinfo?(der_tuxman)

Comment 4

4 years ago
I can confirm the Services tab always shows, even if you've never used the social API before or have never installed a service add-on, or have the social API completely enabled in about:config as stated in comment 0

The tab shows a blank page with "You don't have any add-ons of this type installed" and is otherwise not used if you don't use the social API. If the API is explicitly disabled, the tab serves absolutely no purpose, ever, so should indeed not be shown, IMHO.

Updated

4 years ago
Blocks: 550048
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: SocialAPI → Add-ons Manager
Ever confirmed: true
Flags: needinfo?(der_tuxman)
Product: Firefox → Toolkit
social.enabled is being removed as a pref in bug 894806 and social will be enabled if there is one enabled social provider installed.  The social tab should only appear if there are any installed social providers, as other tabs (e.g. themes).
Created attachment 8359807 [details] [diff] [review]
hide service tab in about:addons

this hides the service tab if no providers are installed

Updated

4 years ago
Depends on: 873671, 894806

Comment 7

2 years ago
Shane:

Shane:

Should this get checked in?
It could.  It breaks at least one test, so there is some work to be done...
FYI, the failing test is browser_social_activation.js although I don't totally understand why it's failing.
So the problem is here:

https://dxr.mozilla.org/mozilla-central/source/browser/base/content/test/social/browser_social_activation.js#232

The test navigates to addons://list/service, but since that page doesn't exist anymore, it defaults to the first page. So then later on in the test when they try to remove the social provider, it doesn't work.

After activating the provider, we need to switch the addons manager to the services tab. I tried BrowserOpenAddonsMgr('addons://list/service'); but that opens a new window and breaks things.

Comment 11

5 months ago
I don't have the bug # handy but the social api has been removed
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX

Comment 12

5 months ago
It would be very helpful to know the bug# for removal of the social API. I did a search but came up with zilch.

Comment 13

5 months ago
See bug 1388902.
You need to log in before you can comment on or make changes to this bug.