Closed Bug 917338 Opened 6 years ago Closed 2 years ago

CompositionManager.setComposition() should be able to specify composition clause style

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, enhancement)

ARM
Gonk (Firefox OS)
enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: masayuki, Unassigned)

References

Details

(Keywords: inputmethod)

Gecko supports that IME can specify composition string's clause style in C++ level.

We've not implemented API to access it from JS yet. However, if this bug is accepted by B2G team, I'll implement it on nsICompositionStringSynthesizer.

Note that this is NOT necessary until 3rd party IME becomes available on Firefox OS because vendor can specify the composition string style of each attribute by prefs such as:

ui.IMERawInputUnderlineStyle
ui.IMESelectedRawTextUnderlineStyle
ui.IMEConvertedTextUnderlineStyle
ui.IMESelectedConvertedTextUnderlineStyle
ui.IMEUnderlineRelativeSize
ui.IMERawInputBackground
ui.IMERawInputForeground
ui.IMERawInputUnderline
ui.IMESelectedRawTextBackground
ui.IMESelectedRawTextForeground
ui.IMESelectedRawTextUnderline
ui.IMEConvertedTextBackground
ui.IMEConvertedTextForeground
ui.IMEConvertedTextUnderline
ui.IMESelectedConvertedTextBackground
ui.IMESelectedConvertedTextForeground
ui.IMESelectedConvertedTextUnderline

When 3rd party IME will be available, IME should be able to specify the composition string's clause style via API.
I'm not sure if it is necessary to allow IME to customize the composition style. Will it be enough to provide some pre-defined style for the 3rd party IME?
(In reply to Yuan Xulei [:yxl] from comment #1)
> I'm not sure if it is necessary to allow IME to customize the composition
> style.

It's indeed luxurious request, though.

> Will it be enough to provide some pre-defined style for the 3rd party
> IME?

I guess that it's not enough for them who want this feature.

I'll ask the purpose about this to Japanese IME vendor at next meeting with them. After that, I'll feedback their thought.
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #2)
> I'll ask the purpose about this to Japanese IME vendor at next meeting with
> them. After that, I'll feedback their thought.

I happened to came across this bug. So how was the meeting goes and did this requirement get mentioned? I also wonder if any other mobile platforms provide similar API for the IME apps. If so, it would serve as a justification for us to support too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(masayuki)
As far as I know, the android IME has the capability of specifying composition clause style, but iOS's doesn't.
Sorry for the delay to report.

When we discussed it, they said that currently it's not important because FxOS doesn't support 3rd party Japanese IME. For the performance of converting with dictionary, it's impossible to implement Japanese IME only with JS. Therefore, Japanese IME must be preinstalled at shipping products. So, they can use ui.* prefs for customizing the IME selection styles.

However, for the future, we should support it. I believe so. Even though iOS doesn't support it, the feature must be useful for IME vendors.

If you agree with this feature support, I'll write the patch for Gecko part. I guess I can work on this mid or late this month.
Flags: needinfo?(masayuki)
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #5)
> If you agree with this feature support, I'll write the patch for Gecko part.
> I guess I can work on this mid or late this month.

I have no opinion on this feature since I don't know what's the impact to Japanese IME, if the API does not provide this capability. I do however thinks we shouldn't blindly exposed what's offered internally in Gecko, maybe a subset of it would be enough.

Thanks!
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #6)
> (In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #5)
> > If you agree with this feature support, I'll write the patch for Gecko part.
> > I guess I can work on this mid or late this month.
> 
> I have no opinion on this feature since I don't know what's the impact to
> Japanese IME, if the API does not provide this capability. I do however
> thinks we shouldn't blindly exposed what's offered internally in Gecko,
> maybe a subset of it would be enough.
> 
> Thanks!

FYI: This feature in Gecko is implemented for TSF mode of Windows. And we can do same thing for Linux (GTK) too. Mac OS doesn't support this feature.

If this feature is supported, IME vendors can include additional information of converting string with different style text. This is usually used by 3rd-party's IME for desktop in Japan. I'm really not sure if this is necessary for smartphones. However, if Firefox OS should be used with PC like hardware like Chromebook in the future, then, this feature must be useful. (If 3rd party IME is available on Firefox OS at that time, though.)
Bruce, could you add this item to the product log so any partner inquiries can be properly pointed to the feature here? Thanks.
Flags: needinfo?(bhuang)
Flags: needinfo?(bhuang)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.