The default bug view has changed. See this FAQ.

Starting a simulator changes host and port settings

RESOLVED FIXED in Firefox 26, Firefox OS v1.2

Status

()

Firefox
Developer Tools: WebIDE
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jryans, Assigned: paul)

Tracking

({verifyme})

Trunk
Firefox 27
verifyme
Points:
---

Firefox Tracking Flags

(firefox26 verified, firefox27 verified, b2g-v1.2 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Right now, there's only one set of host and port settings in the connection footer.

If you start a simulator, the port will likely change to a randomly chosen port at startup time.  If you later want to connect to a device, you'll have to edit the port back to 6000 first, then connect.

Generally, it feels like we may need to rethink the flow of the connection footer to make it simpler to preserve the device settings.
(Assignee)

Comment 1

4 years ago
If you re-use the connection used by the Simulator, indeed.

When the simulator closes, we should kill the connection as well, and create a new one.
(Assignee)

Comment 2

4 years ago
(not critical for 26)
No longer blocks: 912913
(Assignee)

Updated

4 years ago
Priority: -- → P1
(Assignee)

Comment 3

4 years ago
Created attachment 810563 [details] [diff] [review]
Patch v1
Attachment #810563 - Flags: review?(poirot.alex)
(Assignee)

Updated

4 years ago
Whiteboard: [needed-in-aurora-26]
(Assignee)

Updated

4 years ago
Assignee: nobody → paul
Comment on attachment 810563 [details] [diff] [review]
Patch v1

Needs rebase, connected listener in now a singleton.
Attachment #810563 - Flags: review?(poirot.alex)
The conflicting patch is the one from bug 919681.
(Assignee)

Comment 6

4 years ago
Created attachment 811116 [details] [diff] [review]
Patch V2
Attachment #810563 - Attachment is obsolete: true
Attachment #811116 - Flags: review?(poirot.alex)
(Assignee)

Updated

4 years ago
Whiteboard: [needed-in-aurora-26] → [waiting for review]
Comment on attachment 811116 [details] [diff] [review]
Patch V2

Review of attachment 811116 [details] [diff] [review]:
-----------------------------------------------------------------

FYI: If you launch the simulator and immediatly click on cancel, it doesn't reset to 6000.
Otherwise, the patch works fine in sane usages of the simulator.
Attachment #811116 - Flags: review?(poirot.alex) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Whiteboard: [waiting for review] → [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/d079bd51114c
Keywords: checkin-needed
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/d079bd51114c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
(Assignee)

Comment 10

4 years ago
Comment on attachment 811116 [details] [diff] [review]
Patch V2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: connection params messed up after simulator started
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #811116 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
Whiteboard: [waiting-for-aurora-approval]
Attachment #811116 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/90ad9f7c9795
status-b2g-v1.2: --- → fixed
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Whiteboard: [waiting-for-aurora-approval]

Updated

3 years ago
Keywords: verifyme
Verified as fixed with: latest Aurora 27.0a2, latest Nightly 28.0a1 and latest Beta 26 beta 4, on: Win 7 32-bit, Ubuntu 13.04 32-bit, Mac OS X 10.6.8
status-firefox26: fixed → verified
status-firefox27: fixed → verified
QA Contact: manuela.muntean
You need to log in before you can comment on or make changes to this bug.