Closed Bug 917824 Opened 6 years ago Closed 6 years ago

[Contacts] Use Full Line Highlights

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

All
Other
defect
Not set

Tracking

(blocking-b2g:-)

RESOLVED FIXED
blocking-b2g -

People

(Reporter: epang, Assigned: arnau)

References

Details

(Whiteboard: visual design, visual-tracking, jian)

Attachments

(2 files)

Highlight extends to the edge on the left.  On the right there is a 30px margin to allow for the scroll index.
Flagging as 1.3? since the highlight state currently looks broken.
blocking-b2g: --- → 1.3?
Whiteboard: visual design, visual-tracking → visual design, visual-tracking, jian
triage: would not block release but please land it when its ready
blocking-b2g: 1.3? → -
Assignee: pivanov → arnau
Pavel, I could work in the missing Highlight bugs, if you don't mind.
(In reply to Arnau March from comment #3)
> Pavel, I could work in the missing Highlight bugs, if you don't mind.

This would be great Arnau!  Pavel is really busy with the 1.3 refresh bugs.  Thanks! :)
Flags: needinfo?(arnau)
Attached file patch in github
Attachment #8340959 - Flags: ui-review?(epang)
Attachment #8340959 - Flags: review?(jmcf)
Flags: needinfo?(arnau)
Comment on attachment 8340959 [details]
patch in github

Looks good, thanks Arnau!
Attachment #8340959 - Flags: ui-review?(epang) → ui-review+
Blocks: 945786
Comment on attachment 8340959 [details]
patch in github

thanks Arnau
Attachment #8340959 - Flags: review?(jmcf) → review+
https://github.com/mozilla-b2g/gaia/commit/c6a9570f7d69078f28bf0bd3bee336ca2470d08c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
The patch in this bug removes the overflow hidden attribute from contacts.css and trigger reopening of bug 937291. If this is the case we may need to back this out. (This patch also leaves an empty CSS selector in the stylesheet.

I haven't had the time to look into this yet, but I am currently profiling some code so I may give this a quick test.

Also NI? on Ben so he is aware.
Flags: needinfo?(bkelly)
(In reply to Kevin Grandon :kgrandon from comment #9)
> The patch in this bug removes the overflow hidden attribute from
> contacts.css and trigger reopening of bug 937291. If this is the case we may
> need to back this out. (This patch also leaves an empty CSS selector in the
> stylesheet.
> 

Oh that would be unfortunate. Instead of backing out it could be better to fix it asap. Backing out will imply that we will having visual regressions in contacts. Ni Arnau to look into that and fix asap. 

> I haven't had the time to look into this yet, but I am currently profiling
> some code so I may give this a quick test.
> 
> Also NI? on Ben so he is aware.
Flags: needinfo?(arnau)
Thanks Jose!  To be clear, we mainly need the overflow: hidden attribute added back to the .group-section class.

It would be great if we could add a comment there as well since this is the second time the attribute has been removed in a PR.  Sorry for not putting one there originally!
Flags: needinfo?(bkelly)
I'll work on this right now. Sorry about that, just removed the overflow hidden to be able to show the pressed stated. I will add the comment on the code. This kind of tricks are impossible to know to someone how is out of the loop.
Flags: needinfo?(arnau)
You need to log in before you can comment on or make changes to this bug.