Closed Bug 918032 Opened 7 years ago Closed 7 years ago

Edit option should be shown only for Bookmarks ListViews

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed
fennec 26+ ---

People

(Reporter: sriram, Assigned: lucasr)

References

Details

Attachments

(1 file)

Long press on any ListView in the new (or new new) about:home. The contextmenu shows an edit which inturn shows a "Edit Bookmark" dialog. This should be shown only for bookmarks and not all lists.
Blocks: 917455
Assignee: nobody → lucasr.at.mozilla
Attachment #807427 - Flags: review?(wjohnston) → review+
Setting to track 26, since this is part of the follow-up work to bug 917394.
tracking-fennec: --- → 26+
https://hg.mozilla.org/mozilla-central/rev/554a4bf8032f
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Comment on attachment 807427 [details] [diff] [review]
Top Sites query should include display, bookmarkId, historyId

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 862793 (the new about:home UI)

User impact if declined: This is part of a series of (high priority) UI changes that we'd like to get in for Firefox 26. Here's a summary:
* History and Top Sites are separate pages again
* Thumbnails in the Top Sites page (instead of Bookmarks page)
* When entering Home, Top Sites is always the default page

Testing completed (on m-c, etc.): This patch has been in our Nightly builds for almost a week now. No obvious regressions found. UI tests have been updated accordingly (see bug 917398).

Risk to taking this patch (and alternatives if risky): There is some level of risk involved here as this is not a trivial change. However, we've agreed that these changes are important enough to be worth the risk. We'd like to avoid shipping a rather big UI change in Firefox 26 to then change it all over again in the following release as this would be a too disruptive experience for our users. Given the risk involved and the fact that we're adding/changing strings, it's important to have these patches uplifted as soon as possible.

String or IDL/UUID changes made by this patch: n/a

This is part of new-new-abouthome (see bug 917394)
Attachment #807427 - Flags: approval-mozilla-aurora?
Attachment #807427 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.