Bug 917394 (new-new-about-home)

[fig] Re-arrange about:home tabs as per new design

VERIFIED FIXED in Firefox 26

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: lucasr, Assigned: lucasr)

Tracking

(Depends on 1 bug)

unspecified
Firefox 27
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26+ fixed, firefox27 verified, fennec26+)

Details

Attachments

(1 attachment)

Assignee

Description

6 years ago
Change it to be:

History - Top Sites - Bookmarks - Reading List
Assignee

Updated

6 years ago
Blocks: 917396
Assignee

Updated

6 years ago
Blocks: 917398
Assignee

Comment 1

6 years ago
This patch:
- Moves MostVisited panel to be a top level tab in about:home
- Renames MostVisitedPage to TopSitesPage
- Remove the bookmarks grid from the Bookmarks panel
- Sets TopSites as the default page in all cases
- Adds one string for the new "Top Sites" panel
Attachment #806138 - Flags: review?(sriram)
Comment on attachment 806138 [details] [diff] [review]
Rearrange about:home tabs as per new design

Review of attachment 806138 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.

::: mobile/android/base/home/HomePager.java
@@ +143,5 @@
> +        // On phones, the history tab is the first tab. On tablets, the
> +        // history tab is the last tab.
> +        adapter.addTab(HardwareUtils.isTablet() ? -1 : 0,
> +                Page.HISTORY, HistoryPage.class, new Bundle(),
> +                getContext().getString(R.string.home_history_title));

You could use getString() directly.

@@ +241,5 @@
> +
> +            if (index >= 0) {
> +                mTabs.add(index, info);
> +            } else {
> +                mTabs.add(info);           

Whitespace.

::: mobile/android/base/resources/values/dimens.xml
@@ +81,5 @@
>  
>      <!-- We need to maintain height for the tab widget on History Page
>           since android does not add footer/header divider height to its
>           calculation for wrap_content in LinearLayout.
>           50dp * 3 Views + 30dp padding + 4dp dividers-->

Make this "2 Views".
Attachment #806138 - Flags: review?(sriram) → review+
tracking-fennec: --- → 26+

Updated

6 years ago
Blocks: 917944
Blocks: 917987
Assignee

Updated

6 years ago
Blocks: 918377

Updated

6 years ago
Alias: new-new-about-home
Assignee

Updated

6 years ago
Blocks: 903600
https://hg.mozilla.org/mozilla-central/rev/32b336be0bd7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Depends on: 919228
Depends on: 919516
Depends on: 919227
Depends on: 919234
Status: RESOLVED → VERIFIED
Assignee

Comment 5

6 years ago
Comment on attachment 806138 [details] [diff] [review]
Rearrange about:home tabs as per new design

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 862793 (the new about:home UI)

User impact if declined: This is part of a series of (high priority) UI changes that we'd like to get in for Firefox 26. Here's a summary:
* History and Top Sites are separate pages again
* Thumbnails in the Top Sites page (instead of Bookmarks page)
* When entering Home, Top Sites is always the default page

Testing completed (on m-c, etc.): This patch has been in our Nightly builds for almost a week now. No obvious regressions found. UI tests have been updated accordingly (see bug 917398).

Risk to taking this patch (and alternatives if risky): There is some level of risk involved here as this is not a trivial change. However, we've agreed that these changes are important enough to be worth the risk. We'd like to avoid shipping a rather big UI change in Firefox 26 to then change it all over again in the following release as this would be a too disruptive experience for our users. Given the risk involved and the fact that we're adding/changing strings, it's important to have these patches uplifted as soon as possible.

String or IDL/UUID changes made by this patch: this patch introduces one new string 'Top Sites' for the new about:home page.
Attachment #806138 - Flags: approval-mozilla-aurora?
Depends on: 920930
Depends on: 920935
Attachment #806138 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.