Firefox hangs when loading a page that implements MediaStreamAudioSourceNode

RESOLVED WORKSFORME

Status

()

Core
Web Audio
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Manuela Muntean [Away], Unassigned)

Tracking

25 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
- with Mac OS X 10.9 in 32-bit mode:

Reproducible with the latest Beta - 25 beta 1 - build ID: 20130917123208
Not reproducible with the latest Aurora - build ID: 20130918004001
Not reproducible with the latest Nightly - build ID: 20130918030202

STR

1. Open Firefox 25 beta 1 in 32-bit mode and load http://webaudiodemos.appspot.com/input/index.html in a tab
2. When prompted to share your microphone, click on the "Share selected device" button
3. Start exploring: choose a checkbox to check, choose an effect, etc.

Actual results: after making only one action of the ones described at step 3, Firefox hangs, and it doesn't recover (force quit is the only solution)

Expected results: all actions described at step 3 should be performed without any issues
I don't see this bug on Linux. Is it Mac-only?

Can you get a stack trace from a debug build?
(Reporter)

Comment 2

4 years ago
Created attachment 807715 [details]
Sample of Firefox 25 beta 1.txt

I wasn't able to reproduce this issue on Ubuntu 12.10 32bit.

I didn't find any documentation on how to get a stack trace from a debug build on Mac OS X, only on Win: https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_with_WinDbg

Since this isn't a crash, but only a freeze, I got a very useful idea from Yoric: to Sample a Process via The Activity Monitor.

So, I've followed the STR again, on a clean profile, with Mac OS X 10.8.4 in 32-bit mode, and after Firefox hanged, I've obtained the file attached to this comment.
Is this only happening on Mac OSX when you force Firefox to use 32-bit mode?
(Reporter)

Comment 4

4 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #3)
> Is this only happening on Mac OSX when you force Firefox to use 32-bit mode?

Yes, only on Mac OS X in 32-bit mode
(In reply to Manuela Muntean [:Manuela] [QA] from comment #4)
> Yes, only on Mac OS X in 32-bit mode

Thanks Mihaela, given that I don't see this as a high priority. I don't expect a lot of users use Firefox in this way. Roc, if there's something we can do to help we will but I don't think this needs urgent action.

Comment 6

4 years ago
I cannot reproduce this on a 32-bit Mac binary.  Manuela, do you still see this on latest trunk?
Flags: needinfo?(manuela.muntean)
(Reporter)

Comment 7

4 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #6)
> I cannot reproduce this on a 32-bit Mac binary.  Manuela, do you still see
> this on latest trunk?

on Mac OS X 10.8.4:

1) I can't reproduce this issue with the latest Nightly (build ID: 20131003030203 in 32-bit mode

2) I can't also reproduce with latest beta - 25 beta 4 - build ID: 20131001024718, in 32-bit mode
Flags: needinfo?(manuela.muntean)
(Reporter)

Updated

4 years ago
Blocks: 779297

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.