Closed Bug 918377 Opened 6 years ago Closed 6 years ago

Misc layout fixes on new tab layout in about:home

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed
fennec 26+ ---

People

(Reporter: lucasr, Assigned: lucasr)

References

Details

Attachments

(3 files)

No description provided.
Comment on attachment 807261 [details] [diff] [review]
Fixes some small fallouts from the changes we've made in each page

Looks good. Please test this once on 10" tablets too.
Attachment #807261 - Flags: review?(sriram) → review+
Comment on attachment 807429 [details] [diff] [review]
Move and update header divider code to TopSitesPage

Review of attachment 807429 [details] [diff] [review]:
-----------------------------------------------------------------

I was writing a patch for this and got bored :P
Attachment #807429 - Flags: review?(sriram) → review+
Comment on attachment 807430 [details] [diff] [review]
Remove unnecessary extra touch handling from BookmarksListView

Review of attachment 807430 [details] [diff] [review]:
-----------------------------------------------------------------

Please remove any unnecessary imports (like MotionEvent). r+ with that.
Attachment #807430 - Flags: review?(sriram) → review+
Setting to track 26, since this is part of the follow-up work to bug 917394.
tracking-fennec: --- → 26+
Comment on attachment 807261 [details] [diff] [review]
Fixes some small fallouts from the changes we've made in each page

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 862793 (the new about:home UI)

User impact if declined: This is part of a series of (high priority) UI changes that we'd like to get in for Firefox 26. Here's a summary:
* History and Top Sites are separate pages again
* Thumbnails in the Top Sites page (instead of Bookmarks page)
* When entering Home, Top Sites is always the default page

Testing completed (on m-c, etc.): This patch has been in our Nightly builds for almost a week now. No obvious regressions found. UI tests have been updated accordingly (see bug 917398).

Risk to taking this patch (and alternatives if risky): There is some level of risk involved here as this is not a trivial change. However, we've agreed that these changes are important enough to be worth the risk. We'd like to avoid shipping a rather big UI change in Firefox 26 to then change it all over again in the following release as this would be a too disruptive experience for our users. Given the risk involved and the fact that we're adding/changing strings, it's important to have these patches uplifted as soon as possible.

String or IDL/UUID changes made by this patch: n/a

This is part of new-new-abouthome (see bug 917394)
Attachment #807261 - Flags: approval-mozilla-aurora?
Comment on attachment 807429 [details] [diff] [review]
Move and update header divider code to TopSitesPage

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 862793 (the new about:home UI)

User impact if declined: This is part of a series of (high priority) UI changes that we'd like to get in for Firefox 26. Here's a summary:
* History and Top Sites are separate pages again
* Thumbnails in the Top Sites page (instead of Bookmarks page)
* When entering Home, Top Sites is always the default page

Testing completed (on m-c, etc.): This patch has been in our Nightly builds for almost a week now. No obvious regressions found. UI tests have been updated accordingly (see bug 917398).

Risk to taking this patch (and alternatives if risky): There is some level of risk involved here as this is not a trivial change. However, we've agreed that these changes are important enough to be worth the risk. We'd like to avoid shipping a rather big UI change in Firefox 26 to then change it all over again in the following release as this would be a too disruptive experience for our users. Given the risk involved and the fact that we're adding/changing strings, it's important to have these patches uplifted as soon as possible.

String or IDL/UUID changes made by this patch: n/a

This is part of new-new-abouthome (see bug 917394)
Attachment #807429 - Flags: approval-mozilla-aurora?
Comment on attachment 807430 [details] [diff] [review]
Remove unnecessary extra touch handling from BookmarksListView

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 862793 (the new about:home UI)

User impact if declined: This is part of a series of (high priority) UI changes that we'd like to get in for Firefox 26. Here's a summary:
* History and Top Sites are separate pages again
* Thumbnails in the Top Sites page (instead of Bookmarks page)
* When entering Home, Top Sites is always the default page

Testing completed (on m-c, etc.): This patch has been in our Nightly builds for almost a week now. No obvious regressions found. UI tests have been updated accordingly (see bug 917398).

Risk to taking this patch (and alternatives if risky): There is some level of risk involved here as this is not a trivial change. However, we've agreed that these changes are important enough to be worth the risk. We'd like to avoid shipping a rather big UI change in Firefox 26 to then change it all over again in the following release as this would be a too disruptive experience for our users. Given the risk involved and the fact that we're adding/changing strings, it's important to have these patches uplifted as soon as possible.

String or IDL/UUID changes made by this patch: n/a

This is part of new-new-abouthome (see bug 917394)
Attachment #807430 - Flags: approval-mozilla-aurora?
Attachment #807261 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #807429 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #807430 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.