Closed Bug 918378 Opened 6 years ago Closed 6 years ago

New permissions in Fennec 25 b1

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox25 + verified
firefox26 --- verified
firefox27 --- verified

People

(Reporter: kbrosnan, Assigned: blassey)

References

Details

Attachments

(1 file, 1 obsolete file)

connect and disconnect from Wi-Fi
view Wi-Fi connections

are added. Brad says he can get a patch together to remove them from beta.
Blocks: 866957
Attached patch no_wifi_perms.patch (obsolete) — Splinter Review
Assignee: nobody → blassey.bugs
Attachment #807267 - Flags: review?(mark.finkle)
Although we have a strong suspicion that this could be fixed in b2 without impact to our user base, there is lingering concern about having auto updating users fall off the trains unnecessarily. We're going to want a b1 respin.
We'll want to land to tip and MOBILE250b1_2013091714
Comment on attachment 807267 [details] [diff] [review]
no_wifi_perms.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #807267 - Flags: approval-mozilla-beta?
Attachment #807267 - Flags: approval-mozilla-aurora?
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #807282 - Flags: review?(mark.finkle)
Attachment #807282 - Flags: approval-mozilla-beta?
Attachment #807282 - Flags: approval-mozilla-aurora?
Attachment #807282 - Flags: review?(mark.finkle) → review+
Attachment #807267 - Attachment is obsolete: true
Attachment #807267 - Flags: review?(mark.finkle)
Attachment #807267 - Flags: approval-mozilla-beta?
Attachment #807267 - Flags: approval-mozilla-aurora?
Attachment #807282 - Flags: approval-mozilla-beta?
Attachment #807282 - Flags: approval-mozilla-beta+
Attachment #807282 - Flags: approval-mozilla-aurora?
Attachment #807282 - Flags: approval-mozilla-aurora+
Verified in beta. The code won't do anything on 26/27 until they are on beta in several weeks so verification for those releases is not really needed.
Status: NEW → ASSIGNED
Depends on: 918645
https://hg.mozilla.org/mozilla-central/rev/c301037184db
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Verified fixed on:
Build: Firefox for Android 26.0a2 (2013-09-22) and Firefox for Android 27.0a1 (2013-09-23)
Device: LG Nexus 4
OS: Android 4.2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.