Closed Bug 918535 Opened 8 years ago Closed 8 years ago

Defect - Dismissing the soft keyboard in the start screen requires two taps.

Categories

(Core Graveyard :: Widget: WinRT, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: emtwo, Assigned: jimm)

References

Details

(Whiteboard: feature=defect c=tbd u=tbd p=1)

Attachments

(1 file)

STR:
1) Tap the URL bar => keyboard slides in
2) Tap anywhere on the start screen

Expected results: Keyboard slides back in

Actual results: URL bar slides in on first tap and keyboard on second tap
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=0
Hmm, I'm having trouble reproducing this.
Whiteboard: [preview] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
I can reproduce with a build from yesterday evening, will take a look.
Assignee: nobody → rsilveira
Status: NEW → ASSIGNED
On the first click the urlbar blurs as expected. The focus goes to #main-window but the keyboard is still up. I tried moving the focus to other elements but the keyboard is still there. It's as if the accessibility layer didn't catch that we changed focus.
Hey Rodrigo, will you be taking this Defect during IT#16?  If so, can you provide a point value.
Flags: needinfo?(rsilveira)
Mind if I take this? I'm pretty sure this is down in the UIABridge code of widget.
Assignee: rsilveira → jmathies
Flags: needinfo?(rsilveira)
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=1
Attached patch fixSplinter Review
With this applied in widget the problem should be addressed.
Attachment #812037 - Flags: review?(rsilveira)
Component: General → Widget: WinRT
OS: Windows 8 → Windows 8 Metro
Product: Firefox for Metro → Core
Thanks Jim.  I'll add it.
Blocks: metrov1it16
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: jbecerra
Comment on attachment 812037 [details] [diff] [review]
fix

Review of attachment 812037 [details] [diff] [review]:
-----------------------------------------------------------------

I tried the patch and the issue is fixed. The code looks like is doing a relevant thing :), but I'm not familiar with the widget code to r+ it.
Attachment #812037 - Flags: review?(rsilveira) → feedback+
(In reply to Jim Mathies [:jimm] from comment #6)
> Mind if I take this? I'm pretty sure this is down in the UIABridge code of
> widget.

Thanks for taking it by the way :)
Comment on attachment 812037 [details] [diff] [review]
fix

r? -> bbondy
Attachment #812037 - Flags: review?(netzen)
(In reply to Rodrigo Silveira [:rsilveira] from comment #10)
> (In reply to Jim Mathies [:jimm] from comment #6)
> > Mind if I take this? I'm pretty sure this is down in the UIABridge code of
> > widget.
> 
> Thanks for taking it by the way :)

np :) been meaning to get to it. sorry you had to spend front end time on it.
Comment on attachment 812037 [details] [diff] [review]
fix

Review of attachment 812037 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/windows/winrt/UIABridge.cpp
@@ +177,5 @@
> +    return UIA_E_ELEMENTNOTAVAILABLE;
> +  }
> +
> +  nsCOMPtr<nsIAccessible> child;
> +  nsresult rv = mAccessible->GetFocusedChild(getter_AddRefs(child));

nit: unreferenced local variable rv
Attachment #812037 - Flags: review?(netzen) → review+
https://hg.mozilla.org/mozilla-central/rev/533241317d0f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Went through the following "Defect" for iteration #16 without issues. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-10-16-03-02-02-mozilla-central/

- Went through the original issue described in comment #0 without any issues
- Ensured that the OSK is dismissed while the Navigation App Bar slides to the bottom using a single tap (start screen)
- Ensured that the OSK is dismissed while vieiwng websites using a single tap
- Went through all of the above test cases using full, filled & snapped views without issues
OS: Windows 8 Metro → Windows 8.1
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.