Closed Bug 918588 Opened 6 years ago Closed 6 years ago

Event Emitter: Can't call off after once

Categories

(DevTools :: Framework, defect, P1)

defect

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: jryans, Assigned: jryans)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

The once method stores a wrapped handler, so it's not possible to pass something into off that will remove a single handler.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #807530 - Flags: review?(mratcliffe)
Attachment #807530 - Flags: review?(mratcliffe) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/42d54d6f6d1c
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/42d54d6f6d1c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Whiteboard: [needed-in-aurora-26]
Comment on attachment 807530 [details] [diff] [review]
Properly support off after once with EventEmitter

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: wrong info in the app manager (see bug 919681)
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low 
String or IDL/UUID changes made by this patch: none
Attachment #807530 - Flags: approval-mozilla-aurora?
Priority: -- → P1
Attachment #807530 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.