Closed Bug 918681 Opened 6 years ago Closed 6 years ago

-new-instance flag doesn't work on Windows

Categories

(Core :: General, defect)

24 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 855899

People

(Reporter: intendentedelleacque, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20130911042038

Steps to reproduce:

Open Firefox or Thunderbird, then launch from the command line firefox.exe/thunderbird.exe -new-instance -P


Actual results:

On Linux you will get  the ProfileManager running.
On Windows the flag has no effect.


Expected results:

On Windows too you should get the ProfileManager running.

Note that at the contrary the -no-remote flag works as expected in all OS.
Verified both on 17 and 24 versions
Duplicate of this bug: 918679
Are you sure this flag exists? I don't see it on http://kb.mozillazine.org/Command_line_arguments

There is new-window but no -new-instance.
Flags: needinfo?(intendentedelleacque)
(In reply to Loic from comment #2)
> Are you sure this flag exists? I don't see it on
> http://kb.mozillazine.org/Command_line_arguments
> 
> There is new-window but no -new-instance.

That page is not updated.

See http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/xre/nsAppRunner.cpp#1339 and https://bugzilla.mozilla.org/show_bug.cgi?id=716110

Anyway if I've found now that this bug is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=855899
Flags: needinfo?(intendentedelleacque)
I wasn't aware of that. Well, closed as dupe.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855899
You need to log in before you can comment on or make changes to this bug.