Closed Bug 918709 Opened 7 years ago Closed 7 years ago

[XHR2] open() with disallowed method (HTTP verb) CONNECT doesn't throw

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: hsteen, Assigned: mcmanus)

References

()

Details

(Keywords: dev-doc-needed)

Test case:
http://w3c-test.org/web-platform-tests/master/XMLHttpRequest/open-method-insecure.htm
(See sub-tests at the bottom of this test case)
This seems fixed in recent nightlies (Firefox 31)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
It was actually fixed here:
http://hg.mozilla.org/mozilla-central/diff/20d8f9639b9c/content/base/src/nsXMLHttpRequest.cpp
:)

Fixed by mcmanus who also handled bug 918722 at the same time.
Resolution: WORKSFORME → FIXED
Assignee: nobody → mcmanus
Depends on: 477578
Target Milestone: --- → mozilla31
Duplicate of this bug: 704787
You need to log in before you can comment on or make changes to this bug.