Defect - Regression - Long-tap in url bar, content inputs and links doesn't pop context menu

RESOLVED FIXED in Firefox 27

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sfoster, Assigned: jimm)

Tracking

unspecified
Firefox 27
x86_64
Windows 8
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=tbd u=tbd p=1)

Attachments

(1 attachment, 1 obsolete attachment)

We seem to have lost the long-tap for right-click/contextmenu across the board. In particular we have no touch-friendly way to paste or cut in the urlbar, or text or other field in content.
Assignee

Comment 1

6 years ago
apz or async event work most likely. I'll take a look when I get a chance.
Summary: Regression - Long-tap in url bar, content inputs and links doesn't pop context menu → Defect - Regression - Long-tap in url bar, content inputs and links doesn't pop context menu
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Assignee

Updated

6 years ago
Assignee: nobody → jmathies
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=0
Assignee

Comment 2

6 years ago
Posted patch patch (obsolete) — Splinter Review
The big issue here was that added HasPointMoved check we added in here. I also cleaned up some other stuff - making sure the recognizer gets cleared and a missing flag in the pointerup handler. With this patch in place our press-hold is working reliably again.

This is built on top of bug 915213 so it'll have to wait for that work to land.
Assignee

Updated

6 years ago
Whiteboard: [preview] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=1
Assignee

Updated

6 years ago
Duplicate of this bug: 918172
Assignee

Comment 4

6 years ago
Posted patch patchSplinter Review
Attachment #809220 - Attachment is obsolete: true
Attachment #809341 - Flags: review?(netzen)
Attachment #809341 - Flags: review?(netzen) → review+
https://hg.mozilla.org/mozilla-central/rev/e5b5774cc1d1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Blocks: metrov1it16
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [preview] feature=defect c=tbd u=tbd p=1 → feature=defect c=tbd u=tbd p=1
Temporarily reopening to add to iteration.  Will mark as resolved right after.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.