Intermittent test_pointerlock-api.html | file_screenClientXYConst.html: Pointer should be unlocked

RESOLVED FIXED in Firefox 41

Status

()

defect
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: KWierso, Assigned: xidorn)

Tracking

({intermittent-failure})

unspecified
mozilla41
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox39 wontfix, firefox40 wontfix, firefox41 fixed, firefox-esr31 wontfix, firefox-esr38 wontfix)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=28179973&tree=Fx-Team
using slave: t-w732-ix-089


16:49:20     INFO -  698 INFO TEST-INFO | /tests/dom/tests/mochitest/pointerlock/test_pointerlock-api.html | must wait for focus
16:49:20     INFO -  ++DOCSHELL 0C0CD4F0 == 20 [id = 72]
16:49:20     INFO -  ++DOMWINDOW == 184 (10C4EE30) [serial = 335] [outer = 00000000]
16:49:20     INFO -  ++DOMWINDOW == 185 (10C489D0) [serial = 336] [outer = 10C4EE30]
16:49:20     INFO -  ++DOCSHELL 0C0CC848 == 21 [id = 73]
16:49:20     INFO -  ++DOMWINDOW == 186 (10959A18) [serial = 337] [outer = 00000000]
16:49:20     INFO -  ++DOCSHELL 0C0CDC88 == 22 [id = 74]
16:49:20     INFO -  ++DOMWINDOW == 187 (1095AA10) [serial = 338] [outer = 00000000]
16:49:20     INFO -  --DOCSHELL 134A4718 == 21 [id = 60]
16:49:20     INFO -  ++DOCSHELL 134A4718 == 22 [id = 75]
16:49:20     INFO -  ++DOMWINDOW == 188 (13B45B48) [serial = 339] [outer = 00000000]
16:49:20     INFO -  ++DOMWINDOW == 189 (13B48458) [serial = 340] [outer = 13B45B48]
16:49:20     INFO -  WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv) && subjPrincipal) failed: file e:/builds/moz2_slave/fx-team-w32-d-0000000000000000/build/docshell/base/nsDocShell.cpp, line 8442
16:49:20     INFO -  WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/fx-team-w32-d-0000000000000000/build/layout/base/nsDocumentViewer.cpp, line 2339
16:49:20     INFO -  ++DOMWINDOW == 190 (10960798) [serial = 341] [outer = 10959A18]
16:49:20     INFO -  WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/fx-team-w32-d-0000000000000000/build/layout/base/nsDocumentViewer.cpp, line 2339
16:49:20     INFO -  ++DOMWINDOW == 191 (10973948) [serial = 342] [outer = 1095AA10]
16:49:20     INFO -  ++DOMWINDOW == 192 (109590F8) [serial = 343] [outer = 13B45B48]
16:49:20     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/fx-team-w32-d-0000000000000000/build/netwerk/base/src/nsSimpleURI.cpp, line 266
16:49:20     INFO -  ++DOMWINDOW == 193 (15B1E920) [serial = 344] [outer = 13B45B48]
16:49:20     INFO -  [POINTERLOCK] Starting file_screenClientXYConst.html
16:49:21     INFO -  --DOMWINDOW == 192 (1096ABD8) [serial = 70] [outer = 00000000] [url = chrome://browser/content/browser.xul]
16:49:21     INFO -  --DOMWINDOW == 191 (10F37578) [serial = 90] [outer = 00000000] [url = chrome://browser/content/browser.xul]
16:49:21     INFO -  --DOMWINDOW == 190 (10C4DE38) [serial = 80] [outer = 00000000] [url = chrome://browser/content/browser.xul]
16:49:21     INFO -  --DOMWINDOW == 189 (0CEB0A58) [serial = 289] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameReplace.html?clean&window]
16:49:21     INFO -  --DOMWINDOW == 188 (101E26A0) [serial = 284] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameReplace.html?clean&frame]
16:49:21     INFO -  --DOMWINDOW == 187 (134B18D8) [serial = 272] [outer = 00000000] [url = http://example.com/tests/dom/tests/mochitest/localstorage/frameQuotaSessionOnly.html?clear]
16:49:21     INFO -  --DOMWINDOW == 186 (0CEA9CD8) [serial = 258] [outer = 00000000] [url = https://test2.example.com/tests/dom/tests/mochitest/localstorage/frameQuotaSessionOnly.html?clear]
16:49:21     INFO -  --DOMWINDOW == 185 (10C40EA0) [serial = 220] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameMasterEqual.html]
16:49:21     INFO -  --DOMWINDOW == 184 (13B44B50) [serial = 228] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameMasterNotEqual.html]
16:49:21     INFO -  --DOMWINDOW == 183 (15B26D70) [serial = 237] [outer = 00000000] [url = https://example.com/tests/dom/tests/mochitest/localstorage/frameSlaveNotEqual.html]
16:49:21     INFO -  --DOMWINDOW == 182 (15B26450) [serial = 236] [outer = 00000000] [url = http://example.com/tests/dom/tests/mochitest/localstorage/frameMasterNotEqual.html]
16:49:21     INFO -  --DOMWINDOW == 181 (13B5D3B0) [serial = 229] [outer = 00000000] [url = http://example.org:8000/tests/dom/tests/mochitest/localstorage/frameSlaveNotEqual.html]
16:49:21     INFO -  --DOMWINDOW == 180 (10C4BE48) [serial = 221] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameSlaveEqual.html]
16:49:21     INFO -  --DOMWINDOW == 179 (13B4C438) [serial = 204] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameMasterNotEqual.html]
16:49:21     INFO -  --DOMWINDOW == 178 (13B58190) [serial = 205] [outer = 00000000] [url = http://example.com/tests/dom/tests/mochitest/localstorage/frameSlaveNotEqual.html]
16:49:21     INFO -  --DOMWINDOW == 177 (15B32AC8) [serial = 244] [outer = 00000000] [url = https://test2.example.com/tests/dom/tests/mochitest/localstorage/frameQuota.html?clear]
16:49:21     INFO -  699 INFO TEST-KNOWN-FAIL | /tests/dom/tests/mochitest/pointerlock/test_pointerlock-api.html | file_screenClientXYConst.html: mousemove is fired twice.
16:49:21     INFO -  --DOCSHELL 107AEB40 == 21 [id = 61]
16:49:21     INFO -  700 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/pointerlock/test_pointerlock-api.html | file_screenClientXYConst.html: Pointer should be unlocked
16:49:21     INFO -  701 INFO TEST-PASS | /tests/dom/tests/mochitest/pointerlock/test_pointerlock-api.html | file_screenClientXYConst.html: Pointer should be locked
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Does anyone have an idea about the cause of this bug? With OMTC on this seems to practically be a perma-fail but I can't see how it could be related to OMTC, unless it's purely a timing thing. (OMTC will change timings fairly significantly)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
As of this push:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=83849e385943

test_pointerlock-api.html became perma-orange on Windows 7 debug (mochitest-4) - which we believe is due to a chunking change and another test not cleaning up after itself or similar.

As such we've had to disable this test for now, to get the trees green:
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/6534bace5511
Summary: Intermittent TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/pointerlock/test_pointerlock-api.html | file_screenClientXYConst.html: Pointer should be unlocked → Intermittent test_pointerlock-api.html | file_screenClientXYConst.html: Pointer should be unlocked
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(In reply to Ed Morley [:edmorley UTC+0] from comment #55)
> test_pointerlock-api.html became perma-orange on Windows 7 debug
> (mochitest-4) - which we believe is due to a chunking change and another
> test not cleaning up after itself or similar.

To expand on this, we use chunk-by-dir in the mochitest-plain suite (which means that the chunking decisions are based on the number of test directories). Bug 995385 added a new dom/crypto/test/ directory, which pushed dom/tests/mochitest/general/ from mochitest-3 into mochitest-4. It's our suspicion that a test in that directory is what's causing the problems.

Johnny, I'm not really sure who owns pointerlock these days or who should be investigating this. Can you suggest someone? I guess it's not horribly urgent given that we already disabled the test to get the tree reopened, but I also don't want to see this fall through the cracks.
Flags: needinfo?(jst)
Assignee: emorley → nobody
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Posted patch 919106.patchSplinter Review
Attachment #8549679 - Flags: review?(ryanvm)
Comment on attachment 8549679 [details] [diff] [review]
919106.patch

Review of attachment 8549679 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/tests/mochitest/pointerlock/mochitest.ini
@@ +24,5 @@
>    file_allowPointerLockSandboxFlag.html
>    iframe_differentDOM.html
>  
>  [test_pointerlock-api.html]
> +skip-if = toolkit == "windows" || buildapp == 'b2g' || toolkit == 'android' || e10s # Bug 919106 # b2g(window.open focus issues (using fullscreen)) b2g-debug(window.open focus issues (using fullscreen)) b2g-desktop(window.open focus issues (using fullscreen))

Please cleanup the B2G redundancy while you're here (it's cruft from the manifest conversions done long ago). Please also reference bug 931445 for Windows since it's the main driver for disabling at this point.

So something like # B2G - window.open focus issues using fullscreen, Windows - bug 919106 & bug 931445

Thanks for doing this!
Attachment #8549679 - Flags: review?(ryanvm) → review+
Whiteboard: [test disabled on Windows][leave open]

Updated

4 years ago
Blocks: 633602
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(Assignee)

Comment 73

4 years ago
Posted patch patchSplinter Review
Attachment #8623429 - Flags: review?(ryanvm)
(Assignee)

Updated

4 years ago
Blocks: 1165158
I think a Try run of this + bug 1165158 would be the best way to get a rubberstamp.
(Assignee)

Comment 75

4 years ago
try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=78bfa62e2136

This patch is marked with bug XXX in this try push because I wasn't aware of this bug when I pushed that.
Comment on attachment 8623429 [details] [diff] [review]
patch

Review of attachment 8623429 [details] [diff] [review]:
-----------------------------------------------------------------

Not sure I'm really an eligible reviewer for this, but the Try results look great on Linux. Thanks for fixing up this badly in need of love test!
Attachment #8623429 - Flags: review?(ryanvm) → review+
Assignee: nobody → quanxunzhen
Flags: needinfo?(jst)
https://hg.mozilla.org/mozilla-central/rev/1e17258d3213
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [test disabled on Windows][leave open]
Target Milestone: --- → mozilla41
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.