Closed Bug 919418 Opened 9 years ago Closed 5 years ago

[B2G][Helix][Audio][tianhuajian]The camera can record incall ringtone sound

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

Tracking

(tracking-b2g:backlog, b2g-v2.2 affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: lecky.wanglei, Unassigned)

References

Details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba)

Steps to reproduce:

A is FFOS phone , B is another phone
1. A open the camera app
2. A take video recording by using camera app
3. B call A
4. A connect the call
5. A disconnect the call
6. A open the video player
7. Play the video file recorded by camera app



Actual results:

7. In the video file end , it  has ringtone sound


Expected results:

7. The video file has no ringtone sound
【Test Count*】:5
【Found Count*】:5
【Gaia commit ID*】: V1.1HD
【Gecko commit ID*】:  1.1.0 HD
【Log*】:
【Network environment】:
【Resume operation】:
Flags: needinfo?(wchang)
I find in audio hal layer, the audio first change audio device, then stopRecording , and it is the reason the camera record has ringtone sound.

Line 2658: 09-22 10:12:38.621: WARN/AudioHardwareMSM76XXA(169): rpc_snd_set_device(58, 1, 0)
Line 2826: 09-22 10:12:39.351: INFO/QCameraHWI(169): stopRecording: X
Hi Bruce, is this a bug or do you want to backlog this?
Flags: needinfo?(wchang) → needinfo?(bhuang)
Edge case, backlogging.
Flags: needinfo?(bhuang)
Severity: normal → major
Priority: -- → P2
Hi Beatriz,
This issue Mozilla think is a edge case and backlogging it.
We hope you can check whether this case is a issue, 
and if we do not fix this issue on our build, Can you support this result?
Thanks. 
(In reply to Bruce Huang (:bhuang) from comment #4)
> Edge case, backlogging.
Flags: needinfo?(brg)
Flags: needinfo?(bhuang)
We agree this is an edge case but we think it is a good improvement in current behaviour. Bruce, can we nominate it to 1.3?
Flags: needinfo?(brg)
Nom for 1.3
blocking-b2g: --- → 1.3?
Flags: needinfo?(bhuang)
Set the category back to Gaia:Camera, because the stopping recording is not controlled by AudioChannel policy. It is controlled by Camera app itself by detecting the visibility change event.
Component: AudioChannel → Gaia::Camera
Hi Bruce,
Do you mean this issue will be resolved on V1.3?
Thanks

(In reply to Bruce Huang (:bhuang) from comment #7)
> Nom for 1.3
Flags: needinfo?(bhuang)
No, it means we will need to consider it for 1.3 depending on resourcing and priorities.
Flags: needinfo?(bhuang)
Bruce, can you triage this with your teams
Flags: needinfo?(bhuang)
Hi,

Please refer to the link as below. This bug should be the same root cause with that one.
https://bugzilla.mozilla.org/show_bug.cgi?id=908525#c51
Component: Gaia::Camera → Gaia::System::Window Mgmt
Nominate it to 1.5 because it needs big effort for fixing the issue.
blocking-b2g: 1.3? → 1.5?
Alive, is this related to bug 927862 like bug 908525? Can we fix bug 927862 in 1.5 time frame?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(bhuang) → needinfo?(alive)
Yes, attention-window is in 1.5 time frame.
Assignee: nobody → alive
Depends on: attention-window
Flags: needinfo?(alive)
Backlog this one and plan it in the future sprint.
Blocks: 908549
No longer blocks: devices-backlog
blocking-b2g: 2.0? → backlog
Assignee: alive → nobody
Is this bug not fixed by bug 927862? qawanted for master branch check.
Keywords: qawanted
Tested with Shallow Flash on 319mb using Engineering builds

This bug DOES exist in the latest Flame 2.2 KK build. Ringtone is heard for the last 5 or so seconds of the video before it stops.

Repro Rate: 3/3

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141110052655
Gaia: e02facadb0bc3fe32227b52b31ca47822f7f4322
Gecko: 1a09297482e1
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.