Bug 905001 (devices-backlog)

[meta] Backlog features for Devices

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: jcheng, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

This is the bug for tracking backlog items for Devices team

Comment 1

5 years ago
Bug 748350 is for sharing files between PC and device via MTP protocol.
The benefit is that

  1. MTP didn't need to unmount storage first then share to PC, so device side can use that storage while MTP is working.

  2. MTP hides the file system type on storage so device can share file with Windows OS even later didn't support ext4.

  3. MTP didn't limited the transfer layer and it can be USB, TCP/IP or others. Currently USB will be high priority.
Depends on: 748350

Comment 2

5 years ago
Bug 841660  is for adding format command into DeviceStorage Web API.
The benefit is that

  1. Once user buy a new SD Card, it can use FxOS device to format it directly.

  2. Currently we support to format it as FAT first.
Depends on: 841660

Comment 3

5 years ago
Bug 886203 is for add support to HDMI output.
The benefit is that

  1. It can add the value in entertainment point of view so we can play a HD/Full HD video on the device but output to more big and high resolution external screen. (ex: like TV).

  2. Some tablet use mini-HDMI slot and some phone use USB slot with MHL.
Depends on: 886203

Comment 4

5 years ago
Bug 910143 is for adding support of FMRadio RDS.
The benefit is that it can

  1. be used by TMC (Traffic Message Channel) and combined with Map Navigator.

  2. provide the meta data of a certain broadcasting channel. (ex: station name, music name)
Depends on: 910143

Comment 5

5 years ago
But 911242 is for decoupling the control between screen and keyboard light.
The benefit is that it can

  1. do power saving.
Depends on: 911242

Comment 6

5 years ago
Bug 911244 is for duck detecting.
The benefit is that

  1. we can support more accessories.
Depends on: 911244

Updated

5 years ago
Depends on: 864327

Updated

5 years ago
Depends on: 901859

Updated

5 years ago
Depends on: 905907

Updated

5 years ago
No longer depends on: 910143

Comment 7

5 years ago
Bug 910150 is for enabling acceleration and gyro sensors individually.

  1. This can save the power.
  2. The web content can focus on processing what events it wants.
Depends on: 910150
Depends on: 919418
Depends on: 897413
Depends on: 915650
Depends on: 859168

Comment 8

5 years ago
Bug 932701 -

Refer to Bug 924383.

The audio playback is a key application on mobile platform so how to guarantee it's performance is important to satisfy user experience. 

Current Situation:

Currently the nice & priority of threads in the background will be set to lower then foreground app. And background app playing audio will be set between foreground & background app.

The problem is

  When foreground is busy, the music player in the background is easy to be noticed about underrun issue.

The rough idea

  ProcessPriorityManager will keep threads related to media playback to equal or higher then foreground app no matter they are in the background or foreground.
Depends on: 932701

Comment 9

5 years ago
Bug 871467 - [AudioChannel] To generate alert tone during in_call state when alarm/notification is fired.

Current Situation:

The alarm didn't fire any sound to notify user during voice_call state so user didn't have a chance to know this alarm.

Rough idea:

AudioChannelService can report what channels are used and their status now.
Then system app can base on these information to fire a "do do do" tone on telephony channel instead of original alarm tone on alarm channel.
Depends on: 871467
Depends on: 942727

Comment 10

5 years ago
Bug 942078 - Video thumbnail generation rule

1. Methodology for selecting thumbnail frame.
   Depend on compressed size of I-Frames to select a big I-Frame as thumbnail.

2. Performance:
   There is no necessary to seek both of video and audio for extracting video frame only.
Depends on: 907587
Depends on: 855952
Depends on: 796791
Depends on: 991552
Depends on: 992156
Depends on: 953019
Depends on: 966678
No longer depends on: 966678
Alias: devices-backlog

Updated

5 years ago
No longer depends on: 919418
No longer depends on: 871467
No longer depends on: 932701
Depends on: 1064660

Comment 11

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.