Closed Bug 919629 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen] [Marketplace]User unable to log in to Persona

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Windows 7
defect
Not set

Tracking

(firefox27 affected, b2g-v1.2 unaffected)

RESOLVED DUPLICATE of bug 919833
Tracking Status
firefox27 --- affected
b2g-v1.2 --- unaffected

People

(Reporter: mclemmons, Assigned: jedp)

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

When user accesses Marketplace App, selection of the gear icon and the sign in/sign up button doesn't reveal the login screen to access Persona

Repro Steps:
1) Updated Buri to Build ID: 20130923040214 Master/m-c
2) Tap Marketplace App
3) Tap gear icon 
4) Tap Sign In/Sign Up button

Actual:
Rotating clockwise arrow spins over Sign In/Sign Up button

Expected:
On screen option to type username and password 

Environmental Variables
Build ID: 20130923040214
Gecko: http://hg.mozilla.org/mozilla-central/rev/f97307cb4c95
Gaia: 3408cc3f6b190c8cd31832fbb8cd2ae571041f29
Platform Version: 27.0a1

Notes:
Repro frequency: 100%, waited one - to - five minutes on each test before retesting
Test Suite Name: (Marketplace)
Link to failed test case: https://moztrap.mozilla.org/manage/case/6115/
See attached: logcat
Why is it Gaia::Homescreen?
(In reply to Cristian Rodriguez (:crdlc) from comment #1)
> Why is it Gaia::Homescreen?

It isn't. We need more information here to figure out where the problem is. It could be right now in:

- Trusted UI
- Marketplace
- Persona Server Side

Jed - Can you find out where the problem is?
Component: Gaia::Homescreen → Gaia::System
Flags: needinfo?(jparsons)
blocking-b2g: --- → koi?
QA Contact: sparsons
Does this reproduce on 1.2? I'm assuming it does, but double check this.
I'll check it out.  mclemmons, thank you for including the build ID and SHAs.
The logcat is pretty short and doesn't seem to shed any light on what's going on (at least, I don't understand the meaning of the wifi etc messages).  

mclemmons, if I'm reading the description correctly, it is consistently failing on first use, after which the phone is being reset.  It would be interesting to know whether, if you cancel the flow at this point with the x button in the upper-left of the sign-in dialog, and try again, it continues to fail.  In other words, it would be helpful to know whether it's dying on first use but only first use.
Flags: needinfo?(mclemmons)
A screenshot of when the problem happens here would be helpful as well.
In response to comment 3
 Jason Smith [:jsmith] 2013-09-23 11:17:30 PDT
Does this reproduce on 1.2? I'm assuming it does, but double check this.

This does not reproduce on 1.2 

Environmental Variables
Build ID: 20130922004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2
(In reply to mclemmons from comment #7)
> In response to comment 3
>  Jason Smith [:jsmith] 2013-09-23 11:17:30 PDT
> Does this reproduce on 1.2? I'm assuming it does, but double check this.
> 
> This does not reproduce on 1.2 
> 
> Environmental Variables
> Build ID: 20130922004001
> Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/63a505ec015c
> Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
> Platform Version: 26.0a2

Okay, that implies this is a Gaia::System regression then. Likely in the trusted UI.
blocking-b2g: koi? → 1.3?
Flags: needinfo?(jparsons)
In response to comment 5  Jed Parsons [:jedp, :jparsons] 2013-09-23 11:57:09 PDT

When user selects the icon (less than symbol <) in the upper left to go to previous screen and selects the gear icon again, the same behavior occurs. The cycling arrow going clockwise after selecting the Sign In/Sign Up button. User is never able to reach the sign-in dialog screen.  

Screenshot attachment provided.
Flags: needinfo?(mclemmons)
This issue was only reproduced on the Buri 1.3 Build ID: 20130923040214

Environmental Variables
Build ID: 20130923040214
Gecko: http://hg.mozilla.org/mozilla-central/rev/f97307cb4c95
Gaia: 3408cc3f6b190c8cd31832fbb8cd2ae571041f29
Platform Version: 27.0a1

Last working build Buri 1.3 Build ID: 20130922040204

Environmental Variables
Build ID: 20130922040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/8b4d14afc4f6
Gaia: 37866768b8abda56d089c8fe96ec5298fc1df696
Platform Version: 27.0a1
RIL Version: 01.01.00.019.197 

This issue does not repro on 1.2.
I think Bug 919833 will fix this.

Sorry I didn't link the PR from this bug and mark that one as a duplicate; I came across the error from a different direction and didn't realize until Jason's sharp eyes caught my other bug that I was probably solving the same problem!
Assignee: nobody → jparsons
(In reply to Jed Parsons [:jedp, :jparsons] from comment #12)
> I think Bug 919833 will fix this.
> 
> Sorry I didn't link the PR from this bug and mark that one as a duplicate; I
> came across the error from a different direction and didn't realize until
> Jason's sharp eyes caught my other bug that I was probably solving the same
> problem!

I'll dupe it forward just cause the patch is on the other bug.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919833
No longer blocks: b2g-central-dogfood
You need to log in before you can comment on or make changes to this bug.