Remote debugger in the webapp runtime broken by bug 880930

RESOLVED FIXED in Firefox 27

Status

Firefox Graveyard
Webapp Runtime
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

Trunk
Firefox 27

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 808742 [details] [diff] [review]
fix_debugger_webapprt

Regression from bug 880930.
We should really get the webapprt-test-chrome tests to run on tbpl!

(If you want to run them locally, you just have to run |mach webapprt-test-chrome|)
Attachment #808742 - Flags: review?(past)
Comment on attachment 808742 [details] [diff] [review]
fix_debugger_webapprt

Review of attachment 808742 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Marco Castelluccio [:marco] from comment #0)
> Regression from bug 880930.
> We should really get the webapprt-test-chrome tests to run on tbpl!

That would be great!

> (If you want to run them locally, you just have to run |mach
> webapprt-test-chrome|)

I tried that, but I get:

Error running mach:

    ['webapprt-test-chrome']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

NameError: global name 'mozinfo' is not defined

  File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line 513, in run_mochitest_webapprt_chrome
    return self.run_mochitest(test_file, 'webapprt-chrome', **kwargs)
  File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line 528, in run_mochitest
    **kwargs)
  File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line 269, in run_desktop_test
    options.app = self.get_webapp_runtime_path()
  File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line 81, in get_webapp_runtime_path
    appname = 'webapprt-stub' + mozinfo.info.get('bin_suffix', '')


Do I have to do anything else first, like have a special .mozconfig?
Attachment #808742 - Flags: review?(past) → review+
(Reporter)

Comment 2

5 years ago
(In reply to Panos Astithas [:past] from comment #1)
> > (If you want to run them locally, you just have to run |mach
> > webapprt-test-chrome|)
> 
> I tried that, but I get:
> 
> Error running mach:
> 
>     ['webapprt-test-chrome']
> 
> The error occurred in the implementation of the invoked mach command.
> 
> This should never occur and is likely a bug in the implementation of that
> command. Consider filing a bug for this issue.
> 
> If filing a bug, please include the full output of mach, including this error
> message.
> 
> The details of the failure are as follows:
> 
> NameError: global name 'mozinfo' is not defined
> 
>   File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line
> 513, in run_mochitest_webapprt_chrome
>     return self.run_mochitest(test_file, 'webapprt-chrome', **kwargs)
>   File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line
> 528, in run_mochitest
>     **kwargs)
>   File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line
> 269, in run_desktop_test
>     options.app = self.get_webapp_runtime_path()
>   File "/Users/past/src/fx-team/testing/mochitest/mach_commands.py", line
> 81, in get_webapp_runtime_path
>     appname = 'webapprt-stub' + mozinfo.info.get('bin_suffix', '')
> 
> 
> Do I have to do anything else first, like have a special .mozconfig?

Quite ironic, yesterday even the mach command has regressed! (because of bug 746243)
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/02e62e85c4ad
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/02e62e85c4ad
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.