[B2G] [Settings] Failed to connect a Bluetooth headset while already connected to another one

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gyeh, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build info
* Gecko: v1.2, 85ead3614a3de104ca8b52c63a5b9b35c68feaa5
* Gaia: v1.2, 9d2150bd26ca5ff639114dfb0058d35ab871dcc0

STR
1. Turn on Bluetooth.
2. Connect to a Bluetooth headset (device A).
3. Tap another paired Bluetooth headset (device B).
4. Tap "Connect".

Expected result:
* A warning message should be shown for user.
* Disconnect with device A.
* Connect to device B.

Actual result:
* A error message is shown: "Check that the device you're trying to connect with is still in range and has Bluetooth turned on."
* Disconnect with device A.
* Didn't connect to device B.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → koi?
(Reporter)

Updated

5 years ago
Blocks: 919868
(Reporter)

Updated

5 years ago
No longer blocks: 919868
(Reporter)

Updated

5 years ago
Blocks: 807758
Triage: Seems to be a regression as previous versions would show a warning message.  koi+
blocking-b2g: koi? → koi+
Assignee: nobody → arthur.chen
Created attachment 810339 [details]
link to https://github.com/mozilla-b2g/gaia/pull/12460

Add a callback in the "setDeviceDisconnect" function to ensure the timing of the disconnection of the previous device. Please help review the change, thanks!
Attachment #810339 - Flags: review?(ehung)

Comment 3

5 years ago
Comment on attachment 810339 [details]
link to https://github.com/mozilla-b2g/gaia/pull/12460

r=me, thanks!
Attachment #810339 - Flags: review?(ehung) → review+
Thanks for reviewing.

master: https://github.com/mozilla-b2g/gaia/commit/3381068ae32d5b1fb0f37eefe030c54c4dbd4494
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 3381068ae32d5b1fb0f37eefe030c54c4dbd4494 to:
v1.2: 16ed9e10f9d9cc90c6437797c790b166f98c7a1f
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.