[Lockscreen] The phone unlock itself if you force turn off the screen before unlock

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: atsai, Assigned: snowmantw)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
If you turn the screen off by power key before unlock, the phone will automatically unlock itself next time you press power key to the lock screen.

STR:
1. Turn on the lock screen feature in settings app (It should be on by default)
2. Press the power key to turn off the screen
3. Press the power key again to turn on the screen
4. Drag the blue ball to unlock screen but hold it still and do not release
5. Press the power key to turn off the screen
6. Press the power key to turn on the screen

Expected Result: 
6. The screen is locked

Actual Result:
6. The screen is unlocked
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919850
(Assignee)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 2

5 years ago
I reopened this bug to separate it from the Bug 919850, which blocks Bug 919858.
They're all going to be fixed, but I shouldn't fix these 3 bugs in one patch.
blocking-b2g: --- → koi?
Assignee: nobody → gweng
blocking-b2g: koi? → koi+
Hi Greg,

Is there a work in progress patch for this ? When is this expected to resolve. I wanted to tie the right 1.2 Convergence target milestone to this bug. Hence the info will be very helpful.
Flags: needinfo?(gweng)
(Assignee)

Comment 4

5 years ago
(In reply to bhavana bajaj [:bajaj] from comment #3)
> Hi Greg,
> 
> Is there a work in progress patch for this ? When is this expected to
> resolve. I wanted to tie the right 1.2 Convergence target milestone to this
> bug. Hence the info will be very helpful.

Yes. Since I just handled a series of lockscreen bugs and the merging issue on v1.2, this bug should be solved within these days.
Flags: needinfo?(gweng)
(Assignee)

Comment 5

5 years ago
Created attachment 817016 [details]
Patch

Restore the slide during screenchange.
Attachment #817016 - Flags: review?(timdream)
Attachment #817016 - Flags: review?(timdream) → review+
(Assignee)

Comment 6

5 years ago
master: https://github.com/mozilla-b2g/gaia/commit/623bdabc5724b05149df76798664608de57d495b

PR passed Travis: https://travis-ci.org/mozilla-b2g/gaia/builds/12556527
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Uplifted 623bdabc5724b05149df76798664608de57d495b to:
v1.2: 0fcea79c5d604a8c725f3fa25708fac08a55eeb5
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.