Closed Bug 920006 Opened 6 years ago Closed 6 years ago

crash in libutils.so@0xf74e (Nexus 10, Android 4.3)

Categories

(Firefox for Android :: Toolbar, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 28
Tracking Status
firefox24 + wontfix
firefox25 + wontfix
firefox26 + wontfix
firefox27 - wontfix
firefox28 - fixed
relnote-firefox --- 24+

People

(Reporter: kats, Assigned: bjacob)

References

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash])

Crash Data

+++ This bug was initially created as a clone of Bug #900020 +++

Bug 900020 was originally filed for a crash + miscellaneous graphical glitches on the on nexus 10 running android 4.3. After some investigation bjacob landed a patch to fix the graphical glitches but it may be that the crash is not fixed yet. This bug is being cloned from that one to track the crashes and fix them if they still occur.
Here's my two recent comments on the actual crash over in the other bug - note that in both cases I saw the graphics glitches in conjunction, we'll see how things end up with that connection.



Bug 900020 Comment #67 - Robert Kaiser (:kairo@mozilla.com) 2013-09-23 05:24:32 PDT

If the graphics issues and the crash are separate, we should do separate bugs for them - possibly cloning the crash into a fresh bug, given that the graphics issue work is going on here.

I had bp-e9e677be-cd1a-483f-9b61-4738b2130922 yesterday but I don't have good STR - it happened after the graphics issue had appeared, I think when I tried to close Nightly.


Bug 900020 Comment #68 - Robert Kaiser (:kairo@mozilla.com) 2013-09-23 13:27:14 PDT

Today I had bp-12faa518-c604-45a3-9105-48d6d2130923 - after the graphics issue appeared late yesterday, I did let Nightly just sit and put the tablet into standby, and when I woke it up today, the crash reporter was waiting for me.
Assignee: nobody → bjacob
Clearing assignee; this doesn't look like a graphics bug, rather this was spun off from bug 900020 after I was done with the graphics things reported there.
Assignee: bjacob → nobody
Thanks!
Thanks!
Kats, you have this device?  Can I borrow it?
Flags: needinfo?(bugmail.mozilla)
I was borrowing Aaron's
Flags: needinfo?(bugmail.mozilla) → needinfo?(aaron.train)
bjacob's got it last I think (also, it's Ian's device).
Milan tells me we're close to identifying the final assignee (Benoit or Kats).
Flags: needinfo?(aaron.train)
Milan - any update on comment 8 & an assignee here?
Flags: needinfo?(milan)
Further conversation with Kats made it plausible that this might have something to do with the surface-renewal stuff which I'm investigating in bug 925608, but I don't know for sure.
Let's leave it assigned to bjacob until the bug 925608 investigation is going on, under the assumption these two are related.
Depends on: 925608
Flags: needinfo?(milan)
If that one helps, we should be able to see that in crash stats. I personally haven't seen the crash since we fixed bug 900020.
Now that bug 925608 is fixed, I would appreciate testing on the latest Nightly build to see if the issues reported here still persist.
We'll need to watch crash-stats to verify, of course, as this was filed "just" based on data.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #14)
> We'll need to watch crash-stats to verify, of course, as this was filed
> "just" based on data.

Any updates here?  Still a topcrash?  We're at the point of wontfixing again at the very least but it would be good to know if the volume has indeed decreased.
Flags: needinfo?(kairo)
This is not a top crash by volume but it does happen on one of the premiere Nexus devices. We would need Google Play data if that shows how many Nexus 10 active installs we have. Over a month it is 1.7k crashes. Over a week it is about 400.

As comment 13 states bug 925608 may have helped but we would need a bigger population to understand the impact.
I cannot add any info over comment #16 so far, I think we'll need to see how bug 925608 fares on beta.
Flags: needinfo?(kairo)
From https://bugzilla.mozilla.org/show_bug.cgi?id=925608#c43 then we will let this ride on FF28 and we can re-evaluate when we get FF28 onto Beta and have more user data
If it's any help, I installed Nightly on my Nexus 10 last week and did not experience any of the erratic drawing behaviour the release version has.
\o/

rjonasz, this fill me with glee.

Can anyone else confirm?
The drawing behavior has been fixed for me since bug 900020 landed. I also haven't seen the crash since then, but we clearly have continued to see it in crash-stats. It will be a while though until we see if bug 925608 has fixed this crash finally, as we have a very small population on Nightly.
https://crash-stats.mozilla.com/report/list?signature=libutils.so%400xf74e doesn't show up on 28, not even when you go to a 4-week view, so I'm cautiously optimistic here.
That said, we also only see 4 cases of 27.0a2 in the last 4 weeks, so I think we only will really know about this once 28 has been on beta for a couple of weeks.
Any update here? Is this one of the Fennec graphics bugs that has been declining?
Flags: needinfo?(kairo)
This was a low volume crash after the fix. I don't see any beta crashes after this week. Though it is a very low volume crash 27 crashes in the last 7 days on 27 release. I can't say for sure if 28 is unaffected at those volume levels.
Even if affected, at such low volumes (and with the help from the graphics fixes) this is not a release-blocking bug worth tracking.
Flags: needinfo?(kairo)
https://crash-stats.mozilla.com/report/list?signature=libutils.so%400xf74e says that it's only appearing for 27 and older, and it was supposed to be fixed with bug 925608 in 28, so I'll declare it fixed there by not seeing this in Beta 28 data.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → bjacob
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.