Closed Bug 920092 Opened 6 years ago Closed 6 years ago

'[object Object]' is displayed when installing certified app failed on production device

Categories

(DevTools :: WebIDE, defect, P1)

defect

Tracking

(firefox26 verified, firefox27 verified)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified

People

(Reporter: ochameau, Assigned: ochameau)

Details

Attachments

(1 file)

When installing an app via the local app page to a device that forbids certified apps, we get an alert dialog with just "[object Object]".
Assignee: nobody → poirot.alex
Attachment #809253 - Flags: review?(paul)
Attachment #809253 - Flags: review?(paul) → review+
Whiteboard: [needed-in-aurora-26]
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/b65d5ea760ce
Keywords: checkin-needed
Whiteboard: [needed-in-aurora-26] → [needed-in-aurora-26][fixed-in-fx-team]
Comment on attachment 809253 [details] [diff] [review]
ensure printing human readable error message on app install error r=paul

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (app manager)
User impact if declined: wrong error message
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #809253 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b65d5ea760ce
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needed-in-aurora-26][fixed-in-fx-team] → [needed-in-aurora-26]
Target Milestone: --- → Firefox 27
Priority: -- → P1
Attachment #809253 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [needed-in-aurora-26] → [land-in-aurora-26]
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:28.0) Gecko/20100101 Firefox/28.0

Reproduced this issue on Nightly from 2013-09-18 with 1.2 Simulator by using a packaged app (email-drawery): an alert with "[object Object]" is displayed when I hit the DEBUG button. 

On Firefox 26 beta 6 (Build ID: 20131118212339), latest Nightly (Build ID: 20131121030201) and Aurora (Build ID: 20131121004004) on Windows 7 64bit, Mac OS X 10.9 and Ubuntu 12.04 32bit, I get an alert dialog with “installationFailed: Installing certified apps is not allowed” (screenshot: http://goo.gl/iTxoLR). Is this the intended message? And is there any need to verify with a device, not only with the Simulator?
Flags: needinfo?(poirot.alex)
The original report is about having a cryptic error message ([Object object] ...) instead of a human comprehensible one (certified apps is not allowed).
So what you describe here sounds good.
Then, there is this behavior difference between 1.2 and 1.3 with certified apps, I think that is due to bug 927108. Its patch has landed on 30th whereas the simulator xpi for 1.2 is based on gecko of the 28th. (you can see gecko/gaia build date in about:addons. The simulator addon version ends up with a date.

I'll spawn new builds of 1.2 and 1.3 addon right now!
Flags: needinfo?(poirot.alex)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

With the 1.2 (build date: 20131125) and 1.3 (build date: 20131126) Simulator on Firefox 26 beta 8 (Build ID: 20131125215016) with a packaged app I get no alert, but in the Console I see the warning: “The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page.”
With a device, the above warning is not initially displayed. Although, after I close and reopen the Console it's shown everytime.

Is this expected?
Flags: needinfo?(poirot.alex)
I think that because bug 915881 landed before this one and allowed installing certified apps.
So with devices/simulator including bug 915881, the app will install and you will be able to debug them.
But without this changeset and with this patch, you should get a meaningfull message telling you that installation failed.
Flags: needinfo?(poirot.alex)
With Fx 27 beta 5 (20140109165205) we have the same behavior as for Fx 26 beta 8 described in Comment 8.

The <<'certified' apps are not fully supported on the App manager.>> message is displayed and the certified apps can be updated/debugged without any alerts.

Marking as verified (per Comment 8 and 9).

Alexandre please change the status flags if there is something I misunderstood. Thank you!
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.