Closed Bug 920523 Opened 8 years ago Closed 8 years ago

Two back button taps required to return visibility of the navigation-toolbar on cancellation of editing

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

27 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 917514

People

(Reporter: aaronmt, Unassigned)

Details

(Keywords: ux-efficiency)

Currently it takes two back button taps, one to dismiss the keyboard and the other to dismiss focus of the URL bar to return visibility of the navigation-toolbar. Thoughts on returning to the state of visibility of the navigation-toolbar on a single back button tap?

I might just be cautious thinking about a scenario where people might not realize that to get back to their tabs and content they have to hit back twice.
This is something that we filed a bug for before (bug 902039) and decided the current approach was better than a single-back (see comments). The conclusion was that since about:home doubles as a "tab" and as a "shortcut mode" you can enter into, the double-back behavior makes that clear.

However, since this keeps coming up, we should revisit the design choices and consider if there's a different way we could do this. Perhaps an overlay, so it's clear that you're in the state of "about:home shortcut"?
Flags: needinfo?(ibarlow)
Heh. There is a very similar discussion happening over here: https://bugzilla.mozilla.org/show_bug.cgi?id=917514#c5
Flags: needinfo?(ibarlow)
I'll mark this one as duplicate of bug 917514 as a wider design discussion is happening there. Feel free to re-open if there's something specific about this bug that is not covered by bug 917514.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 917514
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.