mozinfo.json has crashreporter: false

RESOLVED FIXED in mozilla27

Status

()

Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Trunk
mozilla27
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25 affected, firefox26 affected, firefox27 affected)

Details

Attachments

(1 attachment)

(Assignee)

Comment 1

4 years ago
Also plausible: bug 902619.
(Assignee)

Comment 2

4 years ago
I was wrong, this was from bug 895253, which means it's broken in Firefox 25. :-/

$ grep ^MOZ_CRASHREPORTER ../debug-mozilla-central/config/autoconf.mk 
MOZ_CRASHREPORTER = F


http://mxr.mozilla.org/mozilla-central/source/python/mozbuild/mozbuild/mozinfo.py#76

d['crashreporter'] = substs.get('MOZ_CRASHREPORTER') == '1'
Blocks: 895253
status-firefox24: --- → unaffected
status-firefox25: --- → affected
status-firefox26: --- → affected
status-firefox27: --- → affected
OS: Mac OS X → All
Hardware: x86_64 → All
Summary: OS X mozinfo.json has crashreporter: false → mozinfo.json has crashreporter: false
Version: 22 Branch → Trunk
(Assignee)

Comment 3

4 years ago
Created attachment 810062 [details] [diff] [review]
fix crashreporter key in mozinfo.json when --enable-crashreporter is specified

:-/ At least the patch is small.
Attachment #810062 - Flags: review?(gps)
(Assignee)

Updated

4 years ago
Assignee: nobody → ted

Comment 4

4 years ago
Comment on attachment 810062 [details] [diff] [review]
fix crashreporter key in mozinfo.json when --enable-crashreporter is specified

Review of attachment 810062 [details] [diff] [review]:
-----------------------------------------------------------------

::: python/mozbuild/mozbuild/mozinfo.py
@@ +72,5 @@
>          d["bits"] = 32
>      # other CPUs will wind up with unknown bits
>  
>      d['debug'] = substs.get('MOZ_DEBUG') == '1'
> +    d['crashreporter'] = substs.get('MOZ_CRASHREPORTER') != ''

bool() can take a string argument and does the right thing.
Attachment #810062 - Flags: review?(gps) → review+
(Assignee)

Comment 5

4 years ago
Pushed this to try just to sanity check that we didn't break any crashreporter tests in the interim:
https://tbpl.mozilla.org/?tree=Try&rev=d48d7ac7a4d0
(Assignee)

Comment 6

4 years ago
That's a messy Try run, but apparently Inbound was a mess at the time. Doesn't look like we have any busted crashreporter tests (thankfully).
https://hg.mozilla.org/mozilla-central/rev/d7ff031debcd
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
(Assignee)

Updated

4 years ago
Duplicate of this bug: 921312
You need to log in before you can comment on or make changes to this bug.