Tab doesn't close after clicking cancel

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Andy McKay, Assigned: scolville)

Tracking

x86
Android
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

5 years ago
Start a payment. Get to the credit card page, click cancel. I get stuck on this screen. This is perhaps because the whole flow is in a new tab, as opposed to being in a trusted ui like it is on a device.

http://www.flickr.com/photos/43096515@N00/9941981323/
(Reporter)

Updated

5 years ago
Priority: -- → P2
(Reporter)

Updated

5 years ago
Assignee: nobody → scolville
(Reporter)

Updated

5 years ago
Version: 1.4 → 1.5
(Reporter)

Updated

5 years ago
Duplicate of this bug: 949670
(Reporter)

Updated

5 years ago
Duplicate of this bug: 951905
Status: NEW → ASSIGNED
(Reporter)

Updated

5 years ago
Blocks: 909896
This looks to be dependent on bug 924693 which is resolved verified. However looking both locally and on stage I still see the STR as per this bug.

The net result is tab doesn't close and log is full of 

E/GeckoConsole(23689): [pay] waiting for paymentFailed to appear in scope
E/GeckoConsole(23689): [pay] waiting for paymentFailed to appear in scope
E/GeckoConsole(23689): [pay] waiting for paymentFailed to appear in scope

Filing a new platform bug as it looks like this is a regression.
Depends on: 959230
Bug filed against Firefox for Android. See bug 959230 for details.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 956949
Summary: Tab doesn't close after clicking cancel → [blocked] Tab doesn't close after clicking cancel
Summary: [blocked] Tab doesn't close after clicking cancel → Tab doesn't close after clicking cancel
The blocker bug 959230 has been marked as fixed.

Marking as resolved so this can be re-tested. See bug 959230 for version info.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.