Closed Bug 920934 Opened 6 years ago Closed 6 years ago

[MediaEncoder] Implement AudioOmxEncoder on B2G

Categories

(Firefox OS Graveyard :: General, defect, major)

All
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 879668

People

(Reporter: rlin, Assigned: shelly)

Details

(Whiteboard: [ft:multimedia-platform])

Attachments

(1 file)

Separate audio part from Bug 879668.
We want to have a OmxAudioEncoder for B2G.
blocking-b2g: --- → 1.3+
Whiteboard: [ft:media-recording]
No longer blocks: 879669
Depends on: 879669
Blocks: 923038
Target Milestone: --- → 1.3 Sprint 5 - 11/22
Assignee: nobody → slin
WIP of OMXCodecWrapper depends on attachment 830691 [details] [diff] [review] by Shelly.
It modifies audio related functions and extends the PushInput() functions to support input larger than OMX buffers.
Per discussion offline - video recording is a targeted feature, not committed, which means we don't need to block on this. We should try to get this in for 1.3 still, however.
blocking-b2g: 1.3+ → -
Video encoding is moved to v1.4 per discussion offline with engineer and PM. reset its target milestone to "---" and will plan the sprint again in v1.4
blocking-b2g: - → ---
Target Milestone: 1.3 Sprint 5 - 11/22 → ---
Mark Dup as Bug:879669
The patch would land in this bug. So close this one.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 879669
oh, wrong bug id, should be this one
bug:879668
Duplicate of bug: 879668
Whiteboard: [ft:media-recording] → [ft:multimedia-platform]
No longer blocks: MediaEncoder, 923038
No longer depends on: 879669
You need to log in before you can comment on or make changes to this bug.