Closed Bug 923038 Opened 6 years ago Closed 6 years ago

[Meta][User Story] Record video clip from standard API (OmxEncoder + MP4) for Camera / Camcorder

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S1 (14feb)

People

(Reporter: itsay, Assigned: itsay)

References

Details

(Keywords: meta, Whiteboard: [ucid:multimedia3, 1.4, ft:multimedia-platform][NPOTB])

This is the user story meta bug for media recording v1.3
Provide Encoding support for OmxEncoder + MP4, VP8 + WebM.
blocking-b2g: --- → 1.3+
Whiteboard: [ucid:mediacording3, ft:media-recording, 1.3:p1]
Keywords: meta
Whiteboard: [ucid:mediacording3, ft:media-recording, 1.3:p1] → [ucid:mediacording3, ft:media-recording, 1.3:p1][NPOTB]
Change the title to reflect the correct user stories
Summary: [Meta][User Story] Video recording standard API → [Meta][User Story] Video encoder and interface for media recording
Depends on: 879669
Depends on: 879668, 881840, 883749, 891704, 891705, 904363, 904366, 920934
No longer depends on: 879669
No longer depends on: 904363, 904366
No longer depends on: 881840
No longer depends on: 891705
No longer depends on: 883749
Target Milestone: --- → 1.3 Sprint 6 - 12/6
Flags: in-moztrap?(pyang)
(In reply to Ivan Tsay (:ITsay) from comment #1)
> Provide Encoding support for OmxEncoder + MP4, VP8 + WebM.

Update the implementation scope to be on video encoding support for OmxEncoder(audio/video) + MP4. So far we narrow down the scope for b2g only. VP8+WebM is mainly for desktop.
Per discussion offline - targeted features don't block, so we don't need to continue blocking on this.
blocking-b2g: 1.3+ → -
Moved out of scope for 1.3, so pulling from tracker bug.
No longer blocks: 1.3-media-recording
Reset target milestone since this on is moved to v1.4
blocking-b2g: - → ---
Target Milestone: 1.3 Sprint 6 - 12/6 → ---
Update whiteboard tag to follow format [ucid:{id}, {release}:p{1,2}, ft:{team-id}]
Whiteboard: [ucid:mediacording3, ft:media-recording, 1.3:p1][NPOTB] → [ucid:mediacording3, 1.3:p1, ft:media-recording][NPOTB]
Update to P2 in whiteboard since this is target feature.
Whiteboard: [ucid:mediacording3, 1.3:p1, ft:media-recording][NPOTB] → [ucid:mediacording3, 1.3:p2, ft:media-recording][NPOTB]
Whiteboard: [ucid:mediacording3, 1.3:p2, ft:media-recording][NPOTB] → [ucid:mediacording3, 1.4:p1, ft:multimedia-platform][NPOTB]
Whiteboard: [ucid:mediacording3, 1.4:p1, ft:multimedia-platform][NPOTB] → [ucid:multimedia3, 1.4:p1, ft:multimedia-platform][NPOTB]
Summary: [Meta][User Story] Video encoder and interface for media recording → [Meta][User Story] Record video clip from standard API (OmxEncoder + MP4)
All the dependency bugs are targeted to be finished by the end of sprint 2
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
No longer depends on: 920934
Closing - all dependent eng. bugs are fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 961925
Depends on: 853356
Paul - gUM camera support isn't needed to test this feature (and isn't related actually) - gUM video isn't captured in MP4. You need to use media streams derived from mp4 files.
No longer depends on: 853356
Hi Jason,
Although it can be tested by media stream instead, it doesn't make any sense if we commit to have video recording without camera enabled.
(In reply to Paul Yang [: pyang] from comment #12)
> Hi Jason,
> Although it can be tested by media stream instead, it doesn't make any sense
> if we commit to have video recording without camera enabled.

There's a separate intention being tracked here for this user story that's not dependent on camera support. Product should be able to clarify the need.
(In reply to Jason Smith [:jsmith] from comment #13)
> (In reply to Paul Yang [: pyang] from comment #12)
> > Hi Jason,
> > Although it can be tested by media stream instead, it doesn't make any sense
> > if we commit to have video recording without camera enabled.
> 
> There's a separate intention being tracked here for this user story that's
> not dependent on camera support. Product should be able to clarify the need.

Agree that product should clarify.
ni? Marvin
Flags: needinfo?(mkhoo)
agree this verification should not have any dependency.
Flags: needinfo?(mkhoo)
Assign to EPM for tracking purpose.
Assignee: nobody → itsay
Whiteboard: [ucid:multimedia3, 1.4:p1, ft:multimedia-platform][NPOTB] → [ucid:multimedia3, 1.4, ft:multimedia-platform][NPOTB]
Target Milestone: 1.3 C2/1.4 S2(17jan) → 1.4 S1 (14feb)
Sadly with the existence of bug 973504, this doesn't achieve a FC signoff, so based on our new FC signoff criteria, this user story is being reopened.
Status: RESOLVED → REOPENED
Depends on: 973504
Resolution: FIXED → ---
No longer depends on: 973504
Move to v1.5 due to feature de-scoping in v1.4.
Blocks: 2.0-multimedia
No longer blocks: 1.4-multimedia
Whiteboard: [ucid:multimedia3, 1.4, ft:multimedia-platform][NPOTB] → [ucid:multimedia3, 1.5, ft:multimedia-platform][NPOTB]
Target Milestone: 1.4 S1 (14feb) → ---
Recover the target milestone field
Target Milestone: --- → 1.4 S1 (14feb)
(In reply to Ivan Tsay (:ITsay) from comment #18)
> Move to v1.5 due to feature de-scoping in v1.4.

This isn't what we discussed offline. We weren't pulling video recording from 1.4 unless there's a regression risk present in the feature currently, which isn't the case based on the analysis I gave.
Flags: needinfo?(itsay)
(In reply to Jason Smith [:jsmith] from comment #20)
> (In reply to Ivan Tsay (:ITsay) from comment #18)
> > Move to v1.5 due to feature de-scoping in v1.4.
> 
> This isn't what we discussed offline. We weren't pulling video recording
> from 1.4 unless there's a regression risk present in the feature currently,
> which isn't the case based on the analysis I gave.

If we want to claim this feature complete in v1.4, we need the full QA test on this. We cannot say it is completed with code landed only. By the decision made in drivers meeting, for the feature that has been fully landed, we just leave it and turn it off. But it does not mean the QA will put effort to test on it.  Actually I am confused if QA will still cover the test for the landed feature other than DSDS and QC blockers.
Flags: needinfo?(itsay) → needinfo?(jsmith)
If the feature will be tested, We shall keep this one in v1.4 as it is a fully landed feature before de-scoping.
(In reply to Ivan Tsay (:ITsay) from comment #21)
> (In reply to Jason Smith [:jsmith] from comment #20)
> > (In reply to Ivan Tsay (:ITsay) from comment #18)
> > > Move to v1.5 due to feature de-scoping in v1.4.
> > 
> > This isn't what we discussed offline. We weren't pulling video recording
> > from 1.4 unless there's a regression risk present in the feature currently,
> > which isn't the case based on the analysis I gave.
> 
> If we want to claim this feature complete in v1.4, we need the full QA test
> on this. We cannot say it is completed with code landed only. By the
> decision made in drivers meeting, for the feature that has been fully
> landed, we just leave it and turn it off. But it does not mean the QA will
> put effort to test on it.  Actually I am confused if QA will still cover the
> test for the landed feature other than DSDS and QC blockers.

No, that's not what we decided on the drivers meeting. If the feature has already fully landed & it does not have regression risk to rest of the product (self-contained), then it can stay in the release until proven otherwise. Paul is actively testing this & I'll be assisting, so this is being looked into. However, I don't think the argument presented is compelling to currently argue this out of the release, as we need proof of either severe bugs or regressions to turn off the feature if it's fully landed. This stays in 1.4 as it stands.
Blocks: 1.4-multimedia
No longer blocks: 2.0-multimedia
Flags: needinfo?(jsmith)
Whiteboard: [ucid:multimedia3, 1.5, ft:multimedia-platform][NPOTB] → [ucid:multimedia3, 1.4, ft:multimedia-platform][NPOTB]
Turns out the issue I saw wasn't related to Video recording, so closing the story out again.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Summary: [Meta][User Story] Record video clip from standard API (OmxEncoder + MP4) → [Meta][User Story] Record video clip from standard API (OmxEncoder + MP4) for Camera / Camcorder
Flags: in-moztrap?(pyang)
You need to log in before you can comment on or make changes to this bug.