[Buri] Italics is over filtered



Firefox OS
5 years ago
22 days ago


(Reporter: tchung, Unassigned)


({polish, regression})

Gonk (Firefox OS)
polish, regression

Firefox Tracking Flags




(3 attachments)



5 years ago
Created attachment 810901 [details]

See screenshot.   seems like there's some over filtering applied to Italics, and now the fonts look like its being blown over by a hurricane.

Need a 1.2 device to test if this affects mozilla-aurora.  

1) install m-c buri build
Gaia:     623e7be3a47dd33df1c64509e6ba0b26b0550b82
Gecko:    http://hg.mozilla.org/mozilla-central/rev/153aebb30387
BuildID   20130926112034
Version   27.0a1
2) launch any page that uses italics (eg. Settings App > Cell & Data > Data 
3) Verify text that uses italics seems over filtered.

- remove the italics filtering, so it looks more as what you would expect with italic fonts

- italics are blown over

Comment 1

5 years ago
What other pages have italics? I don't have a sim card in my phone so I can't check the cell & data page.


5 years ago
Component: Gaia::System → Gaia::Settings
Keywords: polish, regressionwindow-wanted

Comment 2

5 years ago
Created attachment 810924 [details]
Same screen on a keon

Hm, I can't reproduce this on a keon. I built this afternoon.

We might need to update the set of fonts on the buris.
We should at least remove |text-decoration: italic| in CSS.

Not blocking because it's UI issue.
blocking-b2g: koi? → -
Whiteboard: [good first bug]
Clearing regressionwindow-wanted - it's a minor bug, so probably doesn't warrant a regression window upon further analysis.
Keywords: regressionwindow-wanted

Comment 5

5 years ago
(In reply to Michael Wu [:mwu] from comment #2)
> Created attachment 810924 [details]
> Same screen on a keon
> Hm, I can't reproduce this on a keon. I built this afternoon.
I hit this on Helix master/m-c as well.   Another place to look is wifi settings, turned off.  (see attachment)

> We might need to update the set of fonts on the buris.

I was told that visual design team is wanting to default Fiero font as the default for 1.2, and the blown over italics is a possible bug from the implementation.   I agree that its a blocking- due to UI, polish; but i wanted Visual Design team to get a chance to chime in first.   ni? patryk for thoughts.  Patryk, should this block 1.2 or can it be deferred?
Flags: needinfo?(padamczyk)

Comment 6

5 years ago
Created attachment 812311 [details]
screenshot helix wifi screen
The new Fira Sans fonts give us full support for Greek Modern and Cyrillic, so its not just a stylistic change. We can't ship fonts looking like this... hyper italic, none of our competitors would ship anything like this, so I'd block it to get it fixed. Low quality can't be the Firefox OS differentiator. 

Also this is not "polish". Polish is suppose to make something great, even better. Like getting a new car, and then polishing it. The term polish should never be applied to things that are clearly broken.
Flags: needinfo?(padamczyk)

Comment 8

5 years ago
Patryk, this is more of a side-effect of our builds than anything else. Once we switch to a proper 1.2 base image, this problem will go away.


5 years ago
Component: Gaia::Settings → Builds


5 years ago
Duplicate of this bug: 922346


5 years ago
Component: GonkIntegration → Vendcom

Comment 10

4 years ago
Since this problem is expected to go away, I'm removing good-first-bug status.
Whiteboard: [good first bug]

Comment 11

22 days ago
Firefox OS is not being worked on
Last Resolved: 22 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.