[Flatfish][Lockscreen] screen clock is too small on tablet

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gasolin@mozilla.com, Assigned: gasolin@mozilla.com)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v1.2 fixed, b2g-v1.3 fixed)

Details

Attachments

(5 attachments)

(Assignee)

Description

5 years ago
Current lockscreen clock looks not good on tablet

expect:

port clock style from gaia-local https://github.com/gaia-local/gaia/blob/master/apps/system/style/lockscreen/lockscreen.css
(Assignee)

Comment 1

5 years ago
Created attachment 811028 [details]
current lockscreen clock
(Assignee)

Updated

5 years ago
Summary: [Flatfish][Lockscreen] screen clock is too small → [Flatfish][Lockscreen] screen clock is too small on tablet
(Assignee)

Comment 2

5 years ago
Created attachment 811031 [details]
clock modified

@helen, is it looks right for lockscreen clock on tablet?
Flags: needinfo?(hhuang)
(Assignee)

Updated

5 years ago
Assignee: nobody → gasolin
(Assignee)

Comment 3

5 years ago
Created attachment 812993 [details]
lockscreen clock follow 9/27 spec
(Assignee)

Comment 4

5 years ago
Created attachment 813012 [details]
pull request redirect to github
Attachment #813012 - Flags: review?(timdream)
(Assignee)

Updated

5 years ago
Blocks: 903304
Comment on attachment 813012 [details]
pull request redirect to github

Thanks!
Attachment #813012 - Flags: review?(timdream) → review+
@Fred, the distance between time and date is too close, please refer to export image.
(Assignee)

Comment 7

5 years ago
Created attachment 813022 [details]
fix top-padding between date and time

show helen offline and she has some suggestions. here's after-tuning screenshot
(Assignee)

Comment 8

5 years ago
Comment on attachment 813012 [details]
pull request redirect to github

merge style changes into lockscreen-header class
Attachment #813012 - Flags: review?(timdream)
(Assignee)

Comment 9

5 years ago
nominate for koi since its low risk and could improve look and feel when user first see the lockscreen on tablet
blocking-b2g: --- → koi?
Attachment #813012 - Flags: review?(timdream) → review+
(Assignee)

Comment 10

5 years ago
merged to gaia-master https://github.com/mozilla-b2g/gaia/commit/434bfb50ffeedf1ff5b9a1d3bf94c5717687872a

thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(hhuang)
Resolution: --- → FIXED
(In reply to Fred Lin [:gasolin] from comment #9)
> nominate for koi since its low risk and could improve look and feel when
> user first see the lockscreen on tablet

Cannot block on this issue as this does not meet the blocking criteria. Please request approval-gaia-v1.2 on this so this can be uplifted to 1.2.
blocking-b2g: koi? → -
Flags: needinfo?(timdream)
Flags: needinfo?(gasolin)
(Assignee)

Comment 12

5 years ago
Comment on attachment 813012 [details]
pull request redirect to github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 
[User impact] if declined: lockscreen clock is small on tablet
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky): low risk, not effect phone
[String changes made]:
Attachment #813012 - Flags: approval-gaia-v1.2?
(Assignee)

Updated

5 years ago
Flags: needinfo?(timdream)
Flags: needinfo?(gasolin)

Updated

5 years ago
Attachment #813012 - Flags: approval-gaia-v1.2? → approval-gaia-v1.2+
(In reply to Fred Lin [:gasolin] from comment #9)
> nominate for koi since its low risk and could improve look and feel when
> user first see the lockscreen on tablet

Yeah, this statement is to be used for approval, not blocking.

Fred, please uplift this patch manually as uplifters over covers blocking bugs. Thanks!
Flags: needinfo?(gasolin)
(Assignee)

Comment 14

5 years ago
uplifted to v1.2 4a9a3be36d0e7bbba3860a92dcaba3b01ab095cd
status-b2g-v1.2: --- → fixed
Flags: needinfo?(gasolin)
(Assignee)

Comment 15

5 years ago
fix uplift, not do it clearly... 39d0468564fbbab6cc91daf8d69f3b17a6f75dfb
Already on v1.3
status-b2g-v1.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.