Moz doesn't talk to freeamp via rmp (e.g. the Emusic "Download Entire Album" link)

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: doom, Assigned: law)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010723
BuildID:    2001072408

If you look at an album on the http://www.emusic.com web site, 
you have two choices (1) you can click on just a song (this works
for me, it brings up freeamp and plays) or (2) you can click on 
"Download Entire Album" down at the bottom, and it's supposed to 
bring up the freeamp download manager, and download the entire 
album.  This works in Netscape 4.7x, but not in Mozilla. 

Currently in my "helper applications" I've got MIME type: 
   application/vnd.rn-rn_music_package
associated with 
   /usr/bin/freeamp %s

Here's a suggested album you might look at ("The Best of Godzilla"): 
   http://www.emusic.com/albums/1890/

Unfortunately, I can't find any way to reproduce this bug without 
having an account set-up at Emusic.  All I can suggest is that 
you could create an account, use it to test, and then cancel it 
before the free trial period is up. 

(I believe I've also tried this without the %s there, also 
with no luck). 



Reproducible: Always
Steps to Reproduce:
1.Get an http://www.emusic.com account
2.Install freeamp, associate MIME type "application/vnd.rn-rn_music_package"
with freeamp
3. Look at an album, e.g. 
   http://www.emusic.com/albums/1890/
and go to the bottom and click "Download Entire Album".


Actual Results:  Nothing

Expected Results:  Should've brought up Freeamp's "Download Manager".



This used to crash the browser every time, doing nothing is 
actually a big improvement over the way it used to be.
(Reporter)

Comment 1

18 years ago
I just tried this again with just "freeamp", not "freeamp %s", and 
it behaves a little differently:  It does bring up "freeamp", 
but not the "freeamp download manager", and a short message appears 
in the freeamp window "Skipped Corrupted File".

Comment 2

17 years ago
Dupe of bug 58339 via bug 82933

*** This bug has been marked as a duplicate of 58339 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Sorry, I can see why you might think this was a dupe of bug 58339, 
but I really doubt it.  I certainly don't have a flash plug-in 
(since I wish flash would FOAD and I think all the web "designers" 
who flashed up there sites deserved the lay-offs they recieved). 
That can't be the explanation for this particular freeamp problem. 


Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Let's try that again...reporter, feel free to undupe this again if I'm wrong,
but I think *this* is the problem.

*** This bug has been marked as a duplicate of 95091 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
No, I don't think this is a duplicate of 95091: 
As I think is clear in my original description, this is a broken feature with or
without 
the "%s".  It just behaves slightly differently.

I'm talking about the ability of some sites (e.g. emusic.com) to send multiple
files 
to an audio player (e.g. freeamp) via RMP technology.  RMP evidentally stands 
for "Rich Metadata Package".  There's more information about 
it here: 

    http://www.realnetworks.com/devzone/library/creating/rmp/index.html
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
Joseph: is this a request for supporting RMP (whatever that is?). The link you
provided is out of date, please provide another. And could you describe what in
the world is RMP in a few words?

Or is this about the way mozilla handles %s ?
(Reporter)

Comment 7

17 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=92142

> Joseph: is this a request for supporting RMP (whatever that
> is?). The link you provided is out of date, please provide
> another. And could you describe what in the world is RMP in
> a few words?

Sure.  Looks like realnetworks is having some problems.

"RMP" is either "Real Metadata Package" or "Rich Metatdata
Package" (I've seen both... and the MIME type suggests it
was once "RealNetworks Metadata Package").  It's a way for
the website to tell a helper application some additional
information about the files it's receiving.  Notably (in the
case of emusic.com), it tells Freeamp or Realjukebox some
information about the audio tracks that are about to be
downloaded (e.g. song name, album name and so on).  RMP is
an XML-based format.  (Hint: if you shift-click on one
emusic's little blue "Download Entire Album" buttons, you
can save the associated RMP file, and look at examples of
the format directly).

For the RMP system to work, "application/vnd.rn-rn_music_package"
must be associated with either Freeamp or Realjukebox.

It definitely works for Netscape 4.7x, but not for Mozilla.
(I've also gotten word that it doesn't work for Netscape 6.0
under Windows, but I haven't verified that personally).

This is the only information that Real seems to have up
concerning RMPs at the moment (an old press release):

   http://realnetworks.com/company/press/releases/1999/rjbplus.html?UK=X

They used to have a developer kit up there, too.  Until
they get their act together, I've put up a copy of one of
their pdf files over here:

   http://www.grin.net/~mirthles/data/rmp_docv11.pdf

> Or is this about the way mozilla handles %s ?

No, I think that's a red herring. It's an issue with
communicating with a helper application, so I had to try it
with and without the %s, but it doesn't work in either case.
(Reporter)

Comment 8

17 years ago
I've come across some free albums you can download without
getting an Emusic account, so I can simplify the steps to
reproduce this bug (it would be nice if someone would try):

To reproduce:

1. (a) Install <A HREF="http://www.freeamp.org">freeamp</A>, 
   (b) associate MIME type "application/vnd.rn-rn_music_package" with freeamp:

       Edit->Preferences->Helper Applications->New Type

       Description of type: RMP (Real Multimedia Package)
       File Extension:      rmp
       MIME type:           application/vnd.rn-rn_music_package
       Application to use:  freeamp (or possibly /usr/bin/freeamp, or
/usr/local/bin/freeamp)

2. Click on one of the links below,
and then go to the bottom and click "Download Entire Album".

<UL>
<LI><A HREF="http://www.emusic.com/albums/8360/">Unknown - Greetings From
Burkittsville, MD</A> 
<LI><A HREF="http://www.emusic.com/albums/19077/">Blackalicious - Freestyle
Battle - Chief Xcel vs. Versatile II</A> 
<LI><A HREF="http://www.emusic.com/albums/21657/">Ralph Nader - Ralph Nader 2000
Spoken Word Tracks</A> 
<LI><A HREF="http://www.emusic.com/albums/22029/">Vienna Symphony Orchestra And
The Academy Chamber Choir - Mozart's Requiem In D Minor, K.626</A> 
<LI><A HREF="http://www.emusic.com/albums/22438/">Primitive Radio Gods - White
Hot Peach</A> 
<LI><A HREF="http://www.emusic.com/albums/22777/">Blackalicious - Freestyles ::
Interviews</A> 
<LI><A HREF="http://www.emusic.com/albums/25831/">Various Artists - EMusic -
Better Circuitry Through Living--The EMusic/ACID ReMixes</A> 
</UL>

Desired Behavior:
Freeamp's "Download Manager" should open up, showing a list of
the tracks on the album, and a dynamic status indicator showing
how much of each has been downloaded thus far.

Observed Behavior:

Asks me "do you want to open this with freeamp"? I say yes. 
Nothing happens. 

And
   ps -ax | egrep freeamp | egrep -v egrep
shows no processes. 

NOTE: I would expect that this bug could also be reproduced
with RealJukeBox and/or Windows.
Following the steps to reproduce from comment #8 I see the following behavior
with Linux nightly build 2001-12-07-08:

1)  Install freeamp (the "required" RH6 rpms)
2)  Set up the helper app (/usr/bin/freeamp -- you _must_ use full path,
    extension "rmp"; that is also required, mime type
    application/vnd.rn-rn_music_package)
3)  Go to http://www.emusic.com/albums/8360/
4)  Click on the "Download Entire Album" link (blue rectangle with white
    checkbox)
5)  Get "Do you want to open this?" dialog.  Click OK.
5)  Freeamp download manager starts up and starts downloading files.

So I guess this worksforme.  Joseph, what build are you currently using?  Sorry
this bug has languished for so long....
Assignee: rickg → law
Component: Viewer App → File Handling
QA Contact: rickg → sairuh
Worksforme using linux 2002010808 as well.  Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.