Properly document layers code

RESOLVED DUPLICATE of bug 861377

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 861377
5 years ago
3 years ago

People

(Reporter: nical, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [leave open])

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
Created attachment 811174 [details] [diff] [review]
Document a few more texture client methods
Attachment #811174 - Flags: review?(bjacob)
(Reporter)

Updated

5 years ago
Whiteboard: [leave open]
Comment on attachment 811174 [details] [diff] [review]
Document a few more texture client methods

Review of attachment 811174 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/client/TextureClient.h
@@ +125,5 @@
>    virtual TextureClientSurface* AsTextureClientSurface() { return nullptr; }
>    virtual TextureClientYCbCr* AsTextureClientYCbCr() { return nullptr; }
>  
> +  /**
> +   * Always lock/unlock when accessing the shared data.

It is not clear if that is a statement about what that method does, or general advice to the reader.

@@ +126,5 @@
>    virtual TextureClientYCbCr* AsTextureClientYCbCr() { return nullptr; }
>  
> +  /**
> +   * Always lock/unlock when accessing the shared data.
> +   * if Lock() returns false, do not attempt to access the shared data.

Same.

@@ +142,3 @@
>  
> +  /**
> +   * An ID that is used to match a texture client with his corresponding TextureHost.

This refers to 'an id' which would be a piece of data, but here we have a method.

@@ +142,4 @@
>  
> +  /**
> +   * An ID that is used to match a texture client with his corresponding TextureHost.
> +   * Only the COmpositableClient should be allowed to set or clear the ID.

CO with uppercase O
Attachment #811174 - Flags: review?(bjacob) → review+
(In reply to Nicolas Silva [:nical] from comment #3)
> fixed comments and landed
> https://hg.mozilla.org/integration/mozilla-inbound/rev/b4a1b2767689

    1.12 -// A texture host that supports tiling
    1.13  const TextureFlags TEXTURE_FRONT              = 1 << 12;

That doesn't look like adding documentation.
Flags: needinfo?(nobody)
(Reporter)

Comment 6

4 years ago
(In reply to :Ms2ger from comment #5)
> (In reply to Nicolas Silva [:nical] from comment #3)
> > fixed comments and landed
> > https://hg.mozilla.org/integration/mozilla-inbound/rev/b4a1b2767689
> 
>     1.12 -// A texture host that supports tiling
>     1.13  const TextureFlags TEXTURE_FRONT              = 1 << 12;
> 
> That doesn't look like adding documentation.

Yeah, that comment was just wrong. Looks like a copy-past accident. The change was too small to get its own patch though.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861377
Flags: needinfo?(nobody)
You need to log in before you can comment on or make changes to this bug.