[e.me] e.me search can find hidden apps

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

Attachments

(1 attachment)

1. tap on e.me search bar
2. search for ftu

Expected: FTU app is not found
Actual: FTU app is found and can be launched.
Gaia   64ba02f7bbf70a1877ba9dad6889a17cd25b1d35
SourceStamp e4cd2242cc7d
BuildID 20130927040201
Version 27.0a1
blocking-b2g: --- → koi?

Updated

5 years ago
Blocks: 910302
Does sounds like a feature to me.
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

5 years ago
Created attachment 813146 [details]
Patch v1
Attachment #813146 - Flags: review?(ran)
Comment on attachment 813146 [details]
Patch v1

Works like a charm!
Attachment #813146 - Flags: review?(ran) → review+
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla-b2g/gaia/commit/53935ec1c61b5af7c2b51459bec3fcc0f0ca5004
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Clearing nom - we're no longer taking e.me 1.2 feature changes to 1.2.
blocking-b2g: koi? → ---
(In reply to Jason Smith [:jsmith] from comment #6)
> Clearing nom - we're no longer taking e.me 1.2 feature changes to 1.2.

Looks like this isn't related to the e.me changes at all - I just reproduced this on 1.2 as well.

Can someone nominate this for uplift?
No longer blocks: 910302
(Assignee)

Updated

5 years ago
blocking-b2g: --- → koi?

Updated

5 years ago
blocking-b2g: koi? → koi+
Uplifted 53935ec1c61b5af7c2b51459bec3fcc0f0ca5004 to:
v1.2: cf61b0583c544e691c5c92038406d9d87c3eb379
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.