The italic text appears more sloped

VERIFIED FIXED in Firefox 27

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: over68, Assigned: mattwoodrow)

Tracking

({regression})

27 Branch
mozilla28
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox27+ verified, firefox28 verified)

Details

Attachments

(1 attachment)

Steps to reproduce:

1. Disable hardware acceleration.
2. Restart Firefox.
3. Go to page, for example Arabic italic, https://dl.dropboxusercontent.com/u/95157096/85f61cf7/poz82cb7.html


Actual results:

The italic text appears more sloped with HWA disabled.

Screenshot: http://img28.imageshack.us/img28/750/1jez.png


Also happens with other languages, for example, https://dl.dropboxusercontent.com/u/95157096/85f61cf7/c53wfz58.html

Screenshot: http://img703.imageshack.us/img703/1271/eiu0.png
Blocks: 907926
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Keywords: regression
See Also: → 921302
Matt, can you please help here as this sounds like a regression from 907926.
Assignee: nobody → matt.woodrow
This is a bit gross.

I wanted to un-apply the matrix within DrawTargetCairo, but you can't modify the transform on cairo_scaled_font.
Attachment #825043 - Flags: review?(bas)
Comment on attachment 825043 [details] [diff] [review]
Don't skew twice for cairo fonts

Review of attachment 825043 [details] [diff] [review]:
-----------------------------------------------------------------

I guess it'll have to do.
Attachment #825043 - Flags: review?(bas) → review+
https://hg.mozilla.org/mozilla-central/rev/412123f1e16a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Comment on attachment 825043 [details] [diff] [review]
Don't skew twice for cairo fonts

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 907926
User impact if declined: Double italic on some fonts
Testing completed (on m-c, etc.): Been on m-c for a while
Risk to taking this patch (and alternatives if risky): Very low risk.
String or IDL/UUID changes made by this patch: None
Attachment #825043 - Flags: approval-mozilla-aurora?
Attachment #825043 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Verified as fixed with latest Aurora (build ID: 20131121004004) on Win 7 64-bit.
QA Contact: manuela.muntean
Also verified with latest Nightly, W7 64-bit, build ID: 20131121030201
Status: RESOLVED → VERIFIED
Keywords: verifyme
See Also: 921302
You need to log in before you can comment on or make changes to this bug.